When I attempt to insert a citation or specify a database to use as a bibliography, I get a message that I need to "start" the "reference system" "manually":

enter image description here

I have no idea what a references system is, let alone how to start one ("manually" or otherwise). I've followed all of the steps in the documentation, to no avail.

If it matters, I'm running OS 10.8.2, using a BibTeX file (which I've used without issues in other applications, e.g. LyX) for my references, and I have a fill MacTeX installation in the standard locations on my machine.

UPDATE: It matters.

  • $\begingroup$ Under OS X, if I choose a bib file, I get this. So I am guessing it doesn't work under OS X (although I would like to be wrong). $\endgroup$
    – acl
    Dec 11 '12 at 15:44
  • $\begingroup$ @acl: If I dismiss the the error dialog that I get when I first try to insert a reference, and then try to use the "Database" control at the bottom of the "Insert Citation" dialog, I get the same thing you get, in addition to a repeat of the error above. $\endgroup$
    – orome
    Dec 11 '12 at 15:47
  • $\begingroup$ What about version 10? $\endgroup$
    Oct 21 '14 at 11:49

As explained in the section tutorial/CitationManagement you need to have EndNote or BibTeX for managing your citations. Interaction with both is covered in this tutorial.

Below is the result I obtained using the sample BiBTeX file downloaded here. Don't forget to work in a cell with the Text style (Alt-7 on Windows) when you use this, otherwise the necessary option will be greyed out.

Mathematica graphics

Mathematica graphics Mathematica graphics

I tried it both on Mathematica 8 and 9. Works without a hitch.

  • $\begingroup$ Does anyone know if Endnote support has been added for Macs in V9? $\endgroup$ Nov 30 '12 at 21:57
  • $\begingroup$ I can't find anything relevant there. What does "have" mean? I have a .bib file, what else do I need and how do I "start" it? All the reference says is "In the data source drop-down menu at the bottom of the Insert Citation dialog, choose BibTeX. A dialog will come up asking for you to choose the .bib file to be used for your reference database. Choose the .bib file and Mathematica will load the database. Once Mathematica loads the database, the references will appear in the Insert Citation dialog and you can insert them as in the above examples." But I just get the error above. $\endgroup$
    – orome
    Nov 30 '12 at 23:02
  • $\begingroup$ @raxacoricofallapatorius See update. You have used the wrong entry in the submenu. You should not use the rebuild option. $\endgroup$ Nov 30 '12 at 23:31
  • 1
    $\begingroup$ @raxacoricofallapatorius I have tried it now in both v8 and v9 and it works without problems. I noted that a helper program is started as soon as you are going to use citations. It's called BibTeXLink. I can imagine this is installed as an optional extra during installation and you didn't select to install the extras. Can you positively confirm that the text cursor is blinking in a text-style block (Alt-7) when you open the citation menu? Furthermore, did you select the "Bibliographical Reference..." sub-menu item, the first item shown in the picture above and not any other item? $\endgroup$ Dec 3 '12 at 20:55
  • 1
    $\begingroup$ @raxacoricofallapatorius Paths for BibTeXLink: 1) c:\Program Files\Wolfram Research\Mathematica\8.0\SystemFiles\FrontEnd\Binaries\Windows\BibTeXLink.exe 2) c:\Program Files\Wolfram Research\Mathematica\8.0\SystemFiles\FrontEnd\Binaries\Windows-x86-64\BibTeXLink.exe $\endgroup$ Dec 3 '12 at 20:56

At last (after 2.5 months), an answer from Wolfram "support" regarding my problems with this feature, documentation (and repeated insistence from Wolfram notwithstanding):

It's only presently supported under Windows.


I just found out with the BiBTeX example file, that this one is working under Windows in MM 8. But the BiBTeX file generated by Mendeley Desktop 1.7.1 does not!

Even if I removed the header comment from that file, MM refused to display the entries. Then I removed the file attribute from the entry. Now it is working.

The faulty path export looked like this: file = {:D\:/Dropbox/Literature/2005/Solid-State Electronics/Romanjek et al. - 2005 - Characterization of the effective mobility by split C(V) technique in sub 0.1$\mu$m Si and SiGe PMOSFETs.pdf:pdf},

Now I have to figure out, how to get rid (automatically) of these path entries. The use of the title in the PDF name is quite convenient for the manual search online, but here it causes the trouble.

  • $\begingroup$ When I do all steps written in the tutorial to insert citation on my PC, (WinXP, Mathematica 9.0.1, EndNote 9), the dialog "Insert citation" comes up empty and after at least 5 minutes of a hang up. Looks as if the plug-in was not installed. I have installed the M 9.0.1 version on my machine well after the installation of the EndNote. Should it be another way around? May it be that the option only works with the EndNote X? $\endgroup$ Feb 13 '13 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.