3
$\begingroup$

All I remember doing is changing cell format type (preferences>evaluation>Input and Output) back and forth. Now even when I close and reopen, I cannot get Code Assist to show up. It works fine in existing files, and when I copy and paste from here, but in a completely blank file it does not appear.

I am running V10.4

$\endgroup$
2
  • $\begingroup$ Cell["as", "Input", CellChangeTimes->{{3.711853778736206*^9, 3.711853778812235*^9}}] $\endgroup$
    – jamesson
    Commented Aug 16, 2017 at 6:30
  • $\begingroup$ Let me know if my answer helps. $\endgroup$
    – Kuba
    Commented Aug 16, 2017 at 13:29

1 Answer 1

2
$\begingroup$

Previewing cell contents (Ctrl+Shift+E) and noticing a lack of BoxData may give a clue that the cell is not in a StandardForm.

It can be confirmed/checked by going to menu Cell / Convert To too.

Not sure if this is emphasized anywhere in docs (link appreciated) but syntax highlighting/code assist is available only in StandardForm representation.

You can switch it back via mentioned menu or by pressing Crtl+Shift+N

If the problem is not localized to a specific notebook/cell check if DefaultFormatType options is not set to InputForm for affected objects.

$\endgroup$
3
  • $\begingroup$ Yep, correct. Can I make it default to StandardForm? $\endgroup$
    – jamesson
    Commented Aug 17, 2017 at 20:50
  • $\begingroup$ n/m found it support.wolfram.com/kb/28318 support.wolfram.com/kb/34575 $\endgroup$
    – jamesson
    Commented Aug 18, 2017 at 0:30
  • $\begingroup$ @jamesson good you've figured it out, sorry for the delay. $\endgroup$
    – Kuba
    Commented Aug 18, 2017 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.