1
$\begingroup$

I'm still not sure how to reproduce this, but it is certainly NOT a code-issue. I just hope I'm missing something easy, or this is a known issue with a known workaround.

I have a script that uses ParallelDo and takes several minutes to run. It usually works fine and my CPU is all time close to 100% usage.

Then something changes (not sure, but likely causes are hibernating or --most likely-- running on battery rather than plugged-in) and only one parallel kernels runs at full capacity (at times, two, but no more than that,) and CPU usage rarely reaches 50%.

It wouldn't really be an issue, if it didn't go back to normal after plugging-in, nor after killing the parallel kernels. Not even after quitting the kernel or restarting Mathematica. So far it seems the only solution is restarting Windows. (which makes me think the issue is rather system-related.)

My system configuration is:

  • Dell Inspiron 15, 7000 series
  • 4 cores, 8 logical processors
  • 8 GB RAM
  • Windows 10
  • Mathematica 11.0

Any thoughts would be appreciated.

$\endgroup$
  • 3
    $\begingroup$ Impossible to say what the problem is without more details, also I am not sure if this is the right place to get help with this. Have you tried contacting WRI? $\endgroup$ – Sascha Aug 10 '17 at 13:44
  • $\begingroup$ @Sascha that is my fear. I haven't contacted WRI yet. I just hope this is an issue known enough so that someone else in-site has experienced it. I'm willing to give more details, if you tell me what you think could help $\endgroup$ – Rafael Aug 10 '17 at 13:49
  • $\begingroup$ @Sacha I apologize if this is off-topic, I thought it could fit. I'm willing to post an answer if I get one from WRI and the question is judged on-topic. $\endgroup$ – Rafael Aug 10 '17 at 13:54
2
$\begingroup$

This is just a guess as I am not familiar with parallel processing in Mathematica but I have had similar issues with different software on Windows 10 while using laptops.

Check your "Power Options" under Control Panel -> System and Security -> Power Options.

If your power plan is set to "Power saver" or maybe even "Balanced", this could be causing your drop in performance. See if setting it to always be on "High performance" mode fixes it.

$\endgroup$
  • $\begingroup$ It's been a while now. I still experience the issue. I'm now inclined to think it's not a Mathematica's problem. I've tried lifting a number of power/performance restrictions, but still some apps (not only WM) are prevented from running at their full potential. $\endgroup$ – Rafael Jun 4 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.