3
$\begingroup$

Every time I start Mathematica 11.1, or restart a session after Quit, it takes about 20 seconds on my rMBP 2014 MacOS X 10.10 for the kernel to start up. I just figured out (by switching off my wifi) that this annoying wait time is due to the kernel checking the internet at startup. Without wifi, the kernel launches quickly.

Why is the Mathematica 11.1 kernel checking the internet each time I launch the kernel? and is there an option to switch it off? It's annoying to have to turn off my wifi before starting/restarting Mathematica.

$\endgroup$
  • 3
    $\begingroup$ Yes, there is an option under Preferences -> Internet & Mail. I think it's the same as the $AllowInternet variable. But a 20 s startup time does not sound normal. $\endgroup$ – Szabolcs Aug 8 '17 at 19:28
  • 1
    $\begingroup$ @Szabolcs. I'm pretty much experiencing the same slow startup as the OP with OS X 10.10.2. My experience is turning off Internet access does not cure the problem. $\endgroup$ – m_goldberg Aug 8 '17 at 19:46
  • $\begingroup$ @m_goldberg Apparently, switching off the internet doesn't cure my problem either. It still takes 20 seconds to load. (Once it took 2 minutes!) $\endgroup$ – QuantumDot Aug 12 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.