I recently updated to Mathematica 11 and now the box which suggests what function you might be typing is completely illegible:

enter image description here

Is there any way to change the text / background color in this box or make it go away entirely?

  • $\begingroup$ Are you using the "ReverseColor" style sheet? Which version of Mathematica are you using? $\endgroup$ – Jason B. Jul 13 '17 at 16:10
  • $\begingroup$ I'm on version How do you see / change what style sheet you are using? $\endgroup$ – Madeline Brandt Jul 13 '17 at 16:33
  • $\begingroup$ If you haven't changed the style sheet, then it should be default. I just thought, since it was dark, that you had changed it via the menu: Format -> Stylesheet -> ReverseColor. Since you didn't do that, then you are just using the default. What you're describing sounds like a bug, and I would consult tech support wolfram.com/support/contact $\endgroup$ – Jason B. Jul 13 '17 at 16:37

These are OpenGL issues (apparently affecting OSX in addition to Linux), either caused by a bad graphics driver or lack of memory. If it always happens, it's unlikely to be the latter. Try installing any available software updates. If that doesn't help, send in a report to support and include a notebook with the result of evaluating SystemInformation[].

In order to turn off the the suggestions completely, open the Options Inspector (Ctrl-Shift-O), set the scope of Global Preferences, and search for ShowCodeAssist. Unchecking the True/False box toggles it on and off.

| improve this answer | |
  • 1
    $\begingroup$ It's on a macbook from 2014 $\endgroup$ – Madeline Brandt Jul 13 '17 at 21:30
  • $\begingroup$ Interesting. I'll ask our Mac person if he's encountered this. My answer about how to turn them off is the same, except it's Cmd-Shift-O to open the inspector. $\endgroup$ – Itai Seggev Jul 14 '17 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.