4
$\begingroup$

I made a GIF animation by the following command. The duration of the created GIF was not 1/365 although I specified the option directive "DisplayDurations" to 1/365. I watch the GIF in InternetExplorer 11 and it moved at about two frames per second.

eccentricity = Table[Graphics[{Disk[{0.1 Cos[θ], 0.1 Sin[θ]}, 1], White, Point[{0, 0}]}, 
PlotRange -> {{-1.5, 1.5}, {-1.5, 1.5}}], {θ, 0, 
2 π - (2 π)/365, (2 π)/365}];
Export["eccentricity.gif", eccentricity, "DisplayDurations" -> 1/365];

what is wrong with my way?

$\endgroup$
  • 1
    $\begingroup$ It's happen on me either.But I think this is a problem of your operation maybe.. $\endgroup$ – yode Jul 12 '17 at 11:16
  • 2
    $\begingroup$ You can check the "DisplayDurations" of the gif created by Export using Import["eccentricity.gif", "DisplayDurations"]. The shortest possible seems to be "DisplayDurations" -> 1/100. $\endgroup$ – Karsten 7. Jul 12 '17 at 12:07
  • 2
    $\begingroup$ If I remember correctly 1/100 is the time resolution specified in the GIF89a Specification. $\endgroup$ – Karsten 7. Jul 12 '17 at 12:14
  • 1
    $\begingroup$ There are things to do after your question is answered. It's a good idea to stay vigilant for some time, better approaches may come later improving over previous replies. Experienced users may point alternatives, caveats or limitations. New users should test answers before voting and wait 24 hours before accepting the best one. Participation is essential for the site, please come back to do your part tomorrow $\endgroup$ – rhermans Jul 12 '17 at 17:13
5
$\begingroup$

"DisplayDurations" works fine but there are limits to the values it accepts, and there are also limits on the performance of the software you use to open the file.

IE

I think the main problem is with the browser not allowing such frame rates . Reportedly IE allows only a Maximum Frame-rate ~16 fps. Microsoft claims it's because Legacy compatibility.

But QuickTime Player reports that that GIF file is 100 fps, so something else must be considered.

enter image description here

Limited values for "DisplayDurations"

By inspection (after @Karsten), and based in the format specifications "DisplayDurations" can have values from 1 to 65535 hundredth of a second. Therefore, given values are Mod to 2^16 - 1 and Round to multiples of 1/100 seconds. Zeros are interpreted as infinity ().

Maximum specified frame rate would be 100 fps, but some software may chose to slow that down. Maximum delay, is 655.35 seconds.

There are very few integer number frame rates available, {100, 50, 25, 20, 10, 5, 4, 2, 1}, and the first four are not accepted by IE.

Solution

So, considering the deplorable limitations of IE, you should lower the delay to 0.06. Change your code to

eccentricity = 
  Table[Graphics[{Disk[{0.1 Cos[θ], 0.1 Sin[θ]}, 1], White, Point[{0, 0}]}, 
    PlotRange -> {{-1.5, 1.5}, {-1.5, 1.5}}], {θ, 0, 2 π (1 - 1/16), 2 π/16}];
Export["eccentricity.gif", eccentricity, "DisplayDurations" -> 0.06];

Documentation

It seems to me that the documentation in this case is deficient, as there is no mention on the limits of the values accepted for many options such as "DisplayDurations". So I have submitted a suggestion to the Wolfram Technical Support [CASE:3916297]. If relevant, I will update this answer with the reply, when it happens.

$\endgroup$
  • $\begingroup$ I will use the gif on web. As a circumvent for this problem of supporting only up to 16 fps in I.E., I thought to decrease the frame rate to about 16. As another way, is it possible to use other file formats like .avi or .mp4? If possible, how? $\endgroup$ – Taiki Bessho Jul 12 '17 at 11:30
  • 1
    $\begingroup$ For that you should first read the documentation and then, if in need, ask a new question. Read here $\endgroup$ – rhermans Jul 12 '17 at 13:08
  • 1
    $\begingroup$ @TaikiBessho For AVI there is a "FrameRate" option. $\endgroup$ – Karsten 7. Jul 12 '17 at 20:33
  • 1
    $\begingroup$ @Karsten7. I understood it's more reasonable to use avi format to make such a high frame rate animation. Actually, "FrameRate"->365 did work in Export, thank you. $\endgroup$ – Taiki Bessho Jul 13 '17 at 4:30
  • 1
    $\begingroup$ @TaikiBessho, sorry if my comment came out rude. I truly think it's on everybody's benefit, mainly yours, to ask follow up questions as a different independent question. (you may link to this one for reference) You are not asking too much. We are trying to keep the site useful for everybody, and one of the practices that allow that is to keep each question focused to one point only. It also avoids the frustration of somebody trying to help, but with limited time. It also gives a fresh start to the new question, with wider reach than the subset of people following your previous question. $\endgroup$ – rhermans Jul 13 '17 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.