35
$\begingroup$

Bug introduced in 11.1.1 and fixed in 11.1.1

Bug was caused by a paclet update and fixed by a paclet update.


I downloaded Mathematica this morning to do an implicit polar plot. I attempt to run the code

Manipulate[
ContourPlot[ 
Evaluate@With[{r = Sqrt[x^2 + y^2], \[Theta] = ArcTan[x, y]}, 
{r Cos[Pi \[Theta]/(Pi - 2 chi)] - Exp[1/(r^2 Sin[Pi \[Theta]/(Pi - 2 chi)]^2- 1)] == 0, 
r^2 == 1}], {x, -2, 2}, {y, -2, 2}],
{chi, 0, Pi/4}]

This worked fine. I also wanted to plot the line y==Tan(chi) x, so I added that to the list (right after r^2==1). It did not work, and I got a strange plot. I closed that notebook, and opened a new one, to run the old code that did work. It no longer worked. After that, I started getting the following for every single calculation I attempt:

enter image description here

It just says "running" at the top, and never completes the calculation. It's not frozen. One time I got the following message:

enter image description here

I closed Mathematica, restarted the computer, and tried 1+1 again, and it doesn't work. Next, I followed the instructions on this page. When I try $BaseDirectory and $UserBaseDirectory, I get the same running issue. That didn't work, so I uninstalled Mathematica and reinstalled it. That fixed the issue, but then I went to run my code again and it did the same thing! So somehow this code completely breaks Mathematica to the point where I must reinstall? I'm at a loss.

$\endgroup$
  • 6
    $\begingroup$ I had similar problems today with MMA 11.1.1 and Windows 10. Then I disabled internet connection, deleted all files from the last few days in $UserBasePacletsDirectory, followed the advice to disable MMA internet connectivity given in this answer and re-enabled my internet connection. Now MMA seems to work and FrontEnd doesn't get frozen any more. But I consider this is only as a temporary workaround. $\endgroup$ – Pinti May 14 '17 at 17:52
  • $\begingroup$ In case reinstalling doesn't solve the issue, try uninstalling and then deleting your $UserBaseDirectory (default locations in that link, click on Details) before reinstalling. $\endgroup$ – Emilio Pisanty May 14 '17 at 22:56
  • 1
    $\begingroup$ It appears that Wolfram, Inc. has introduced a serious bug in MMA 11.1.1, which I first encountered late Saturday afternoon, US Central Time. I reported it to Wolfram, Inc this morning. Interestingly, 10.4.1 still works fine, at least on Windows 10 (64 bit). The more people reporting this problem, the better. $\endgroup$ – bbgodfrey May 14 '17 at 23:10
  • 1
    $\begingroup$ Easier solution seems to be installing the previous version until they release an update fixing the bug. $\endgroup$ – user5615 May 17 '17 at 11:16
  • $\begingroup$ I have the same problem with 11.3 Student edition. Even in 1+1 I am getting running! $\endgroup$ – Eyup Jan 17 at 5:31
20
$\begingroup$

For a workaround, launch a standalone kernel and evaluate

PacletSiteUpdate /@ PacletSites[]

PacletUpdate["EntityFramework"]

More detailed instructions can be found here (except substitute "CloudObject" with "EntityFramework").

Please see also this post on Wolfram Community for step by step instructions on all platforms.

$\endgroup$
  • 6
    $\begingroup$ This is very nice of you ! But why not fix the PacletUpdate mechanism once and for all? $\endgroup$ – Rolf Mertig May 14 '17 at 20:58
  • 1
    $\begingroup$ For one friend this was not enough: he needed to evaluate PacletSiteUpdate /@ PacletSites[] first. $\endgroup$ – Rolf Mertig May 14 '17 at 21:29
  • $\begingroup$ Thanks, updated. The linked previous answer has more detailed information. $\endgroup$ – ilian May 14 '17 at 21:34
  • 8
    $\begingroup$ I literally wasted 2 hours of my day reinstalling, cleaning, testing, etc. This is rediculous $\endgroup$ – flip May 14 '17 at 22:33
  • 2
    $\begingroup$ @maybe the issue should be called "Wanna Paclet" ... $\endgroup$ – Rolf Mertig May 15 '17 at 20:50
8
$\begingroup$

I have a similar problem this morning. I open a new notebook and as soon as there is an attempt to start the kernel Mathematica freezes with the cell that is evaluating highlighted and "running."

I did a clean start and that did not fix the problem. I uninstalled and reinstalled Mathematica. Starting Mathematica, opening a new notebook, and evaluating 2+2 produces the same result -- frozen in the running state.

In this state Mathematica does not respond to an abort. So I am without Mathematica right now.

Is it possible Wolfram has done a paclet update that as broken Mathematica?

EDIT:

I moved the paclets directory (In win 7: c:/users/user/appdata/roaming/mathematica/paclets) to the desktop so Mathematic couldn't find it. Then turned off internet access at the OS, and started Mathematica. It starts normally and the kernel loads and returns instantly. Now, how to live without the internet?

This is cross posted here

$\endgroup$
  • $\begingroup$ Interesting, so it's a waiting game? Should I email Wolfram? $\endgroup$ – Ryan Unger May 14 '17 at 16:28
  • 1
    $\begingroup$ @0celouvskyopoulo7 Definitely, YES! The more reports - the more chances this problem will be finally resolved. Notice that it isn't the first time we face such thing - it was in the past and was resolved, BUT apparently the fundamental cause of this still isn't fixed. So definitely report this to the tech support. $\endgroup$ – Alexey Popkov May 14 '17 at 16:40
  • $\begingroup$ The problem above was on my laptop. I also have MMA on my workstation. I tried it there but disabled dynamic updating first and 2+2 worked normally. I then enabled dynamic updating and tried again. It is now also frozen. Both of these computers are running Win7 x64. $\endgroup$ – David Keith May 14 '17 at 16:53
  • $\begingroup$ @DavidKeith Turning off dynamic updating after the freeze doesn't fix it for me. I'm running OSX Yosemite. Writing a support letter now... $\endgroup$ – Ryan Unger May 14 '17 at 17:08
  • 1
    $\begingroup$ @0celouvskyopoulo7 I updated my answer with a fix that is working so far. $\endgroup$ – David Keith May 14 '17 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.