7
$\begingroup$

This question already has an answer here:

We are running Mathematica 11.1 on a remote Linux box that has a pretty locked-down set of ports (enough for SSH and not a whole heck of a lot else), and it keeps trying to update things in the paclet manager, especially when we launch subkernels. This times out (which slows things down annoyingly), and we have a batch workflow set up in a way that makes the generated message very inconvenient.

Is there a way to just turn off the attempts to do the updates? I'm not even sure why it's being done for subkernels in the first place.

UPDATE: After poking around a bit more, I think the issue has something to do with the master kernel deciding to do a paclet update right after LaunchKernels is called; all the subkernels have the -nopaclet command line option, as they should, but starting the master kernel with wolfram -nopaclet causes the error and error message to go away.

$\endgroup$

marked as duplicate by Michael E2, MarcoB, m_goldberg, Community Apr 12 '17 at 21:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ That's weird because subkernels should be launched with the -nopaclet option. EDIT: In fact they are, you can see that with ParallelEvaluate[$CommandLine]. Did you report this problem to WRI? $\endgroup$ – Szabolcs Apr 11 '17 at 20:17
  • $\begingroup$ Do you launch subkernels in the same machine, using the default method? Or do you have a special setup, with your own subkernel launch command? $\endgroup$ – Szabolcs Apr 11 '17 at 20:19
  • $\begingroup$ Same machine, using the default method. See similar problems on Mac OS X and Windows. $\endgroup$ – Pillsy Apr 11 '17 at 20:21
  • $\begingroup$ Well, maybe that -nopaclet doesn't mean much, or maybe it is not handled as it should be. $\endgroup$ – Szabolcs Apr 11 '17 at 20:22
  • $\begingroup$ Have you tried PacletManager`$AllowInternet=False ? $\endgroup$ – Shadowray Apr 11 '17 at 21:13
5
$\begingroup$

You can open Preferences > Internet Connectivity and uncheck Allow the Wolfram System to access the Internet.

Alternatively you can set:

PacletManager`$AllowInternet = False 
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.