2
$\begingroup$

Newcomer to both Mathematica and neural networks here, so please bear with me.

I'm running Mathematica (11.0.1) on a school server (Ubuntu 14.04), accessing it via ssh.

I'm trying to follow the first example from the FeedForward tutorial:

https://reference.wolfram.com/applications/neuralnetworks/tutorial/FeedforwardNetworkExamples.html

(Function Approximation in One Dimension)

Right away I run into trouble: even after having included NeuralNetworks`, "InitializeFeedForwardNet" is not recognized as a function. Skipping down from there, neither are "NetPlot", "NetInformation", or "NeuralFit".

I've tried other examples which begin having the user input a .dat file, and all of those return the error that the file is not found.

Using NeuralNetworks is not entirely a failure, as I can carry out the first example on the main NeuralNetworks page (Digit classification), which involves "NetChain" and "NetTrain".

Does anyone have any idea what might be causing this problem? Please let me know if you can point me towards a link that might help me, or if I should provide any more specific information. Thanks!

$\endgroup$
  • 2
    $\begingroup$ That tutorial is for an older outdated package. $\endgroup$ – M.R. Mar 29 '17 at 22:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.