11
$\begingroup$

Is there any way to achieve smoother scrolling than this:

enter image description here

Why can't notebooks scroll like chrome or safari? I'm using OSX 11.1 on macOS 10.12.4.

$\endgroup$
  • $\begingroup$ It looks like problems of interaction of MMa with X-server on your Mac. I've seen something similar on some builds of Linux.. $\endgroup$ – Rom38 Mar 23 '17 at 16:09
  • 2
    $\begingroup$ @Rom38 There is not X server involved on the Mac. $\endgroup$ – Szabolcs Mar 23 '17 at 16:32
  • 2
    $\begingroup$ Why don't you ask Wolfram Support? The more people complain, the more likely that this issue will be prioritized. I think the problem is related to two things: 1. large and complex graphics objects that are slow to render 2. a non-optimal redraw strategy: that graphics is re-rendered more often than needed. As you noticed, the Mathematica front end fell significantly behind browsers. It wasn't always so. To be fair, browser makes have a lot more resources and manpower to develop their software. But still: the M front end could be faster. $\endgroup$ – Szabolcs Mar 23 '17 at 16:34
  • 1
    $\begingroup$ Had that exact problem for all 10.xx versions. Was so bad I had to use page up and down to scroll through a large notebook. Then it disappeared with 11.0. I hope it has not made a comeback in 11.1... $\endgroup$ – bobbym Mar 24 '17 at 1:34
  • 1
    $\begingroup$ @Rom38 Yes, there are X servers available for Mac, as they are for Windows. But most applications don't use them. Mathematica certainly doesn't, and works without an X server installed. I don't think this problem has anything to do with X servers, or that Mathematica on Mac is comparable in this respect with Mathematica on Linux. $\endgroup$ – Szabolcs Mar 24 '17 at 9:35
5
$\begingroup$

Here is something you might try. It made the scrolling behavior much better for me, although it could still be improved:

Open the Preferences menu and make the adjustment shown in the screen shot here:

prefs

This selects No Antialiasing. On my Mac laptop, the scrolling is significantly improved.

$\endgroup$
  • 3
    $\begingroup$ This has influence on rendering of namely graphical objects. But these settings does not change the jumps during the scrolling of the code in front-end. $\endgroup$ – Rom38 Mar 30 '17 at 8:20
  • $\begingroup$ Yes this has no effect $\endgroup$ – user5601 Nov 6 '17 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.