2
$\begingroup$

I'm using v11.1 on ubuntu, any ideas what is wrong here:

In[3]:= << MXNetLink`
$MXNetLinkLib::loadfail:
   Failed to load MXNetLink library at
    /home/mma/SystemFiles/Components/MXNetLink/LibraryResources/Linux-x86-64/MXNetLink.so.

InitialiazeSymbols::notloaded: Cannot initialize symbols if libraries aren't loaded.

CreateManagedLibraryExpression::nrname:
   The name NDArray is not registered as a library expression manager.

LibraryFunction::libload:
   The function WL_NDArrayCreateEx was not loaded from the file
    /home/mma/SystemFiles/Components/MXNetLink/LibraryResources/Linux-x86-64/MXNetLink.so.

General::interr: An internal error occurred. Please contact Wolfram Research.
$\endgroup$
  • $\begingroup$ Loads fine in 11.0.1 on Win 8.1 Pro and confirmed with ?MXNetLink`*. Don't have 11.1 on this machine so can't verify at the moment. $\endgroup$ – Edmund Mar 22 '17 at 1:16
  • $\begingroup$ Is this because you install Mathematica without root? $\endgroup$ – xslittlegrass Mar 22 '17 at 2:45
  • $\begingroup$ I just confirmed that this works without any errors on 11.1.0 for Linux x86 (64-bit). I did not have root access. $\endgroup$ – dan7geo Mar 22 '17 at 10:01
  • $\begingroup$ Since the problem was due to insufficient permissions, it would have been nice if $MXNetLinkLib::loadfail printed the corresponding error code (EPERM) for this failure, helping the user diagnose the root cause effectively. $\endgroup$ – Bhavin Thaker Mar 22 '17 at 14:23
  • 2
    $\begingroup$ I'm voting to close this question because no one can reproduce the problem and the OP did not respond to comments (essentially: can't be answered without more information). $\endgroup$ – Szabolcs May 6 '17 at 20:35