0
$\begingroup$

I'm having a strange problem with adding data to a Databin.

I have a simple dataset which I've added to directly via Mathematica in a notebook, the first of the 3 rows of the table were added in this way. The 4th row was added via a https call (I have tried via a browser and via the command line with curl). Both methods of https call were successful and the data was added correctly.

RMSD    RunDate    Timestamp
10.1    20170227   2/2017 5:38 pm
4.1     20170228   2/2017 5:38 pm
8.1     20170301   2/2017 5:38 pm
4.3     20170305   2/2017 5:40 pm

When I try to plot the data, I've tried as a BarChart showing RMSD over the 4 days and with a DateListPlot showing RunDate against RMSD, the 4th row isn't shown. The data is clearly there, I can see it in the table and when I examine it in the DataDrop admin panel, but cannot be plotted.

Here's my DateListPlot code, where bin is my Databin (previously defined). The chart only shows 3 points for Feb 27, 28 and Mar 01.

ds = Dataset[bin[All, {"RunDate", "RMSD"}]];
DateListPlot[ds[All, {"RunDate", "RMSD"}]]

Has anyone noticed this before, or any idea why it's happening? I'm completely stumped!

Edit: (more information as requested) I originally created the Databin via the admin panel, and added the first three rows like this:

DatabinAdd[
  bin, <|"ID" -> 17, 
   "SecondID" -> 51, "RMSD" -> 10.1, "Integrate" -> 99.9, 
   "RunDate" -> "20170227"|>];

The fourth row was added via a http call like this,

https://datadrop.wolframcloud.com/api/v1.0/Add?bin=MYBINID&ID=17&SecondID=51&RMSD=4.3&Integrate=98.1&RunDate=20170305

It should be pretty easy to duplicate.

Edit: (more information)

If I create the Databin with semantics, everything works fine. So, without semantics data added via https although present isn't able to be charted.

$\endgroup$
  • 1
    $\begingroup$ We probably need to access the actual data or code to generate it. Can you share it? $\endgroup$ – MarcoB Feb 27 '17 at 19:51
  • $\begingroup$ Thank you for adding some data. I am not sure that it is enough to reproduce your problem though. Since you say that "It should be pretty easy to duplicate", you actually go ahead and duplicate it for us. The less work we have to do to help you, the more likely you are to get a meaningful answer. $\endgroup$ – MarcoB Feb 27 '17 at 23:32
  • $\begingroup$ I suppose the crux is that all's needed is to create a Databin and add some data in two different ways - then display and attempt to plot the data. It displays fine (it's present) but any of the plot commands I've tried doesn't display the data in the plot. $\endgroup$ – FractalDoctor Feb 28 '17 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.