I am currently on a Windows 10 machine using Mathematica and on which I installed the AntykwaTorunska fonts (light, bold, condensed, etc).

Here you can see a part of the screenshot of the Fonts screen from Windows, displaying the most common characters in the Font's style (AntykwaTorunskaLight-Regular). Note how the opening (closing) parenthesis has a thicker end on the top (bottom).

AntykwaTorunskaLight-Regular font Windows

With TeXstudio I can successfully use this font as well by using




Output from LaTeX

Using Mathematica I can show text and parentheses (normal and in bold for completeness) like so:

Style["The quick brown fox jump ()\!\(\*StyleBox[\"(\",\nFontWeight->\"Bold\"]\)\!\(\*StyleBox[\")\",\nFontWeight->\"Bold\"]\)", FontFamily ->"AntykwaTorunska Light", 40]

resulting in output:

AntykwaTorunskaLight-Regular font Mathematica

Conclusion: All the normal text is put out correctly in the ANTTOR font but parentheses seem to misbehave. Is there any way I can get Mathematica to display the parentheses in Mathematica such that they look identical to the ones put out by Windows or LateX?

  • $\begingroup$ Due to lack of reputation I could not give the source (jmn.pl/en/antykwa-torunska) from where I installed the font, nor the output generated by LaTeX (i.stack.imgur.com/y6N6o.png) in the original question. $\endgroup$ – Plint Feb 21 '17 at 11:14
  • $\begingroup$ Can you try if this solution works for you? (I cannot try now) If you only want to use this font for labelling figures that you will later export (perhaps for use in a LaTeX document), consider using my MaTeX package. $\endgroup$ – Szabolcs Feb 21 '17 at 11:18
  • $\begingroup$ Very nice Szabolcs! It does work for parenthesis, but, although not specifically asked in this thread, I also notice that characters like \rho and \beta are not in the correct fonts. Since these are most likely not considered operators it seems " PrivateFontOptions -> {"OperatorSubstitution" -> True} " does not work for those symbols in Mathematica. $\endgroup$ – Plint Feb 21 '17 at 11:55
  • $\begingroup$ To add to this; I also installed MaTeX and tried to change the font to ANTTOR which worked untill I wanted it to output \rho and it gave an error. It seems Mathematica(?) has some issues using Greek symbols or something..? Pretty sure the symbols I want (normal greek ones) are in the font as I can look them up in Windows as well as output them using LaTeX. $\endgroup$ – Plint Feb 21 '17 at 12:43
  • $\begingroup$ MaTeX troubles are a different issue entirely, and it would be better to discuss them elsewhere (do you have enough reputation for chat?). But this works fine: MaTeX[{\[Rho], "\\rho"}, "Preamble" -> {"\\usepackage[light,math]{anttor}"}]. $\endgroup$ – Szabolcs Feb 21 '17 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.