2
$\begingroup$

Now that I found our how to save the private stylesheet opened by "Format->Edit Stylesheet...", by using "File->Save" from that window, I would like to know how to change the "heading" that still says "Private Style Definitions for someNotebook.nb". This is displayed above the "Choose a style" drop-down box button.

Any suggestions?

$\endgroup$
1
  • $\begingroup$ Oh, I think I understand. You don't want it to say "Private Style Definitions" at all but instead "someNotebook.nb style definitions" -- is that right? $\endgroup$
    – Mr.Wizard
    Feb 18, 2017 at 16:14

1 Answer 1

1
$\begingroup$

Within the stylesheet Notebook you need to change the Option:

StyleDefinitions->"PrivateStylesheetFormatting.nb"

to read:

StyleDefinitions->"StylesheetFormatting.nb"

Applying this is complicated by the default stylesheet settings that disable evaluation.
Here is Palette generating code to create a Button to apply it:

CreatePalette@
 Button["Set StylesheetFormatting", 
  SetOptions[SelectedNotebook[], StyleDefinitions -> "StylesheetFormatting.nb"]]

Evaluating that code should create a palette that looks like this:

enter image description here

Open and focus the private style sheet, then click that button and it should immediately apply the change.

Otherwise use a text editor on the Notebook and replace PrivateStylesheetFormatting.nb with StylesheetFormatting.nb.

$\endgroup$
8
  • $\begingroup$ I guess EMacs will also work. ;) $\endgroup$ Feb 19, 2017 at 15:29
  • $\begingroup$ @StevenHatton Directly editing the file is fine too but I am hesitant to recommend it as it is more likely to corrupt a Notebook than the built in tools. Thanks for the Accept. $\endgroup$
    – Mr.Wizard
    Feb 19, 2017 at 15:38
  • 1
    $\begingroup$ FWIW, when I try the first approach, nothing happens. (In fact, nothing happens if I try to evaluate 2 + 2 in a notebook created with Format > Edit Stylesheet...; evaluation seems to be disabled altogether in such notebooks, judging by all the options that are disabled under the Evaluation menu). When I try the second approach, I can find the setting as you described, but I am not able to modify it; i.e. the interface treats this item as "read only". I'm using version 10.4. $\endgroup$
    – kjo
    Mar 20, 2017 at 15:07
  • $\begingroup$ @kjo Thank you! It seems something has changed. Old private style sheets like the one I checked this in allow me to evaluate new cells, but one I created just now to test this did not. $\endgroup$
    – Mr.Wizard
    Mar 21, 2017 at 14:33
  • 1
    $\begingroup$ Clever idea! It worked really well for me. Thanks! $\endgroup$
    – kjo
    Mar 22, 2017 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.