3
$\begingroup$

I have been running Mathematica on a remote cluster for quite sometime. Recently, any jobs that call LaunchKernels[] for parallelization return the error

Get::noopen: Cannot open CloudObjectLoader`

in the output file and terminate. Here's an example that produces this error on the cluster.

LaunchKernels[]

$ProcessorCount

$KernelCount

Do[s=ParallelTable[i+l,{i,10}];,{1000}]

Is the solution to this problem as simple as having the cluster administrator create a Wolfram Cloud account? Thanks!

$\endgroup$
  • $\begingroup$ I do see this error from time to time when I launch parallel kernels on the local machine, but it has never caused any negative effects (such as the subkernels exiting). It also doesn't happen consistently. I did report it to Wolfram but they said that they cannot reproduce it. I have two suggestions for you: 1. Definitely do report the problem to Wolfram, and give as much information as you can to ensure they can reproduce it. 2. Make sure that the subkernels terminating and this error are truly correlated. They may have entirely separate causes. $\endgroup$ – Szabolcs Feb 11 '17 at 9:14
  • $\begingroup$ Could you try RebuildPacletData[] and see if that fixes the issue? $\endgroup$ – Stefan R Feb 13 '17 at 23:00
  • $\begingroup$ Today I got this message for the first time after more than 2 years on a local Windows computer with 4 cores: Get::noopen : Cannot open CloudObjectLoader.` $\endgroup$ – mrz Mar 15 '17 at 14:25
  • $\begingroup$ I am having this CloudObjectLoader not loading issue and not related to parallel processing. I found that it can be temporarily solved by forcing Mathematica to load the package: Get["C:\\Program Files\\Wolfram Research\\Mathematica\\11.0\\SystemFiles\\Links\\CloudObject\\Kernel\\CloudObjectLoader.m"] $\endgroup$ – Gustavo Delfino Mar 20 '17 at 16:12
  • $\begingroup$ I found that the issue is solved by deleting an incomplete CloudObject paclet at "C:\Users\<user>\AppData\Roaming\Mathematica\Paclets\Repository\CloudObject-11.1.1321". $\endgroup$ – Gustavo Delfino Mar 21 '17 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.