3
$\begingroup$

I'm a new user and I'm trying to load a package in Mathematica 11.0.

I've copied the DisturbingFunction.m package to %appdata%\Mathematica\Applications but after this I can't load it. I've tried with

<< DisturbingFunction`
Get[DisturbingFunction`]
Needs[DisturbingFunction`]

but none of this results. In the first two I don't get any message, but in the last I get

Needs::nocont: Context DisturbingFunction` was not created when Needs was evaluated.

Can you figure any reason why is this happening? Thank you!

Edit 1

Following Kuba's suggestion, the first time I run $Packages I get

{"GetFEKernelInit`", "StreamingLoader`", \
"SymbolicMachineLearningLoader`", "IconizeLoader`", \
"HTTPHandlingLoader`", "CloudObjectLoader`", "ResourceLocator`", \
"PacletManager`", "System`", "Global`"}

After running Get

{"CURLInfo`", "CURLLink`Cookies`", "OAuthSigning`", "CURLLink`HTTP`", \
"CURLLink`", "QuantityUnits`", "GetFEKernelInit`", \
"StreamingLoader`", "SymbolicMachineLearningLoader`", \
"IconizeLoader`", "HTTPHandlingLoader`", "CloudObjectLoader`", \
"ResourceLocator`", "PacletManager`", "System`", "Global`"}
$\endgroup$
  • $\begingroup$ That error means that the context wasn't created but there is no error about Get failing to find the file. So probably the package has a non standard structure. Clear the kernel, run $Packages then Get @ "DisturbingFunction`" and $Packages again, what was added? $\endgroup$ – Kuba Feb 1 '17 at 15:26
3
$\begingroup$

When you look inside the DisturbinFunction.m file you see the call

BeginPackage["Perturbations`DisturbingFunction`",
  "Perturbations`Common`PerturbationsCommon`"]

This tells you that this file is part of a larger package Pertubations. Additionally, you see that it needs a second package Perturbations`Common`PerturbationsCommon`.

The easiest way is to ask the author for the complete package.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.