1
$\begingroup$

An atomic orbital demonstration (found here) using DensityPlot3D in Mathematica 11 on MacOS has been causing serious graphical artifacting and crashes.

a0=1;

ψ[{n_, l_, m_}, {r_, θ_, ϕ_}] :=With[{ρ = 2 r/(n a0)}, 
 Sqrt[(2/(n a0))^3 (n - l - 1)!/(2 n (n + l)!)] Exp[-ρ/2] ρ^
  l LaguerreL[n - l - 1, 2 l + 1, ρ] SphericalHarmonicY[l, 
   m, θ, ϕ]]

DensityPlot3D[(Abs@ψ[{3, 2, 0}, {Sqrt[x^2 + y^2 + z^2], 
     ArcTan[z, Sqrt[x^2 + y^2]], ArcTan[x, y]}])^2, {x, -10 a0, 
  10 a0}, {y, -10 a0, 10 a0}, {z, -15 a0, 15 a0}, 
 PlotLegends -> Automatic]

The plot renders correctly, but interacting with Mathematica after the plot is rendered causes red bars to appear across the screen, and manipulating the plot or closing Mathematica will cause the computer to crash entirely. The console is reporting a GPU reset/restart caused by Mathematica, and the panic report refers to a "kernel trap type=14", and an "Intel GPU hang summary". I can upload the full crash report if needed.

Here are images of the artifacting.

I took the computer in for a repair, suspecting a hardware problem, and they replaced the logic board and display, and yet the problem persists. I'm wondering if this is a memory sink or graphics bug in Mathematica, and if there is anything I can do to prevent this from happening.

The computer is a 2015 Macbook Pro, running Mathematica 11.0.1 on MacOS Sierra. I can provide hardware details if needed.

$\endgroup$
  • $\begingroup$ Version 11.0 or 11.0.1? $\endgroup$ – Jason B. Jan 13 '17 at 20:49
  • $\begingroup$ Version 11.0.1.0 $\endgroup$ – JAustin Jan 13 '17 at 20:49
  • $\begingroup$ I don't have Sierra installed, and cannot reproduce it. Email support@wolfram.com, please. $\endgroup$ – rcollyer Jan 13 '17 at 21:02
  • 1
    $\begingroup$ I ran into exactly the same problem rendering my own atomic orbitals / potentials. I suspect the problem has to do with the fact that DensityPlot3D generates Image3D objects. I know my 2012 Macbook Pro had an issue with its GPU and a similar GPU issue could have persisted. Do you experience this more as a session goes on? That's been my experience, but of course that is just subjective. $\endgroup$ – b3m2a1 Jan 13 '17 at 22:10
  • $\begingroup$ I ran your code successfully with V11.0.1 on OS X 10.2.2 (Yosemite) on an iMac i7, 8GB RAM (mid 2010). My GPU is a ATI Radeon HD 5750, 1GB VRAM. No problems whatsoever. In addition to your code, I evaluated other Graphics3D code in the same notebook. No crash on quitting. $\endgroup$ – m_goldberg Jan 13 '17 at 23:57
2
$\begingroup$

I can reproduce this problem on my MacBook Pro:

MacBook Pro (Retina, 13-inch, Early 2015), Processor: 3.1 GHz Intel Core i7, Memory: 16 GB 1867 MHz DDR3, Intel Iris Graphics 6100 1536 MB, macOS Sierra 10.12.2.

The problem ranges from video disruptions to a kernel panic that requires power cycling to recover.

I am running Mathematica 11.0.1.0.

This problem has been reported by others, including on Wolfram's community forum: http://community.wolfram.com/groups/-/m/t/928500 and also here on stackexchange: Does Mathematica 11 work on MacOS Sierra?

I first encountered this problem when looking at the Mathematica documentation for MeanFilter. Accessing that documentation from within Mathematica soon leads to a kernel panic due to the 3D graphics within the documentation page.

A number of commenters have reported that Mathematica 11.0.1.0 fixes the issue for them. The issue is not fixed for our hardware, apparently.

$\endgroup$
  • $\begingroup$ The problem (for my hardware and OS) appears to have been fixed in version Mathematica 11.1. So far I have not been able to reproduce the problems described above. $\endgroup$ – IrrationalMan Mar 17 '17 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.