8
$\begingroup$

This question already has an answer here:

May be this question does not belong to here, but I do not know where to post it.

I am using Windows 10 Pro 64bit and MMA 11.0.1.

My monitor (32inch) has a native resolution of 3820 * 2160 pixels.

When I use an overall screen magnification of 100% the notebook font and the menu items are much too small.

When I increase the screen magnification to 150% or even more the font (independent which one) is extremely blurry.

!!! ALL OTHER WINDOWS AND FONTS IN OTHER APPS ARE SHARP.

Do you have a solution for that, when monitors have 4K?

UPDATE: Answer from a Wolfram Technology Engineer

Mathematica's front-end does not support 4K resolution monitors fully and is known to have some issues when used in 4K resolution monitors. Our developers are currently working on this issue.

$\endgroup$

marked as duplicate by Edmund, LCarvalho, xzczd, Feyre, Mr.Wizard Dec 22 '16 at 17:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

6
$\begingroup$

So this is something I have partially encountered before (though I can't guarantee it will will work for everyone, or even anyone other than me), the first thing I did was to use this tool to fix scaling issues on Win10 (this is an external program, download at your own risk). There is also a possible option modification that may work for you:

  • Open Option Inspector (ctrl shift O)
  • Set to Global Preferences
  • Go to Formatting Options > Font Options > FontProperties
  • Set ScreenResolution to Automatic

Again, there is no guarantee but this is what I have used in the past.

$\endgroup$
  • $\begingroup$ This is genius ... it works for me too ... since 2 years I am suffering with the blurring problem. $\endgroup$ – mrz Dec 22 '16 at 15:04
  • $\begingroup$ The only small thing: The input filed in the Mathematica documentation center is not high enough, I entered here Plot: i.imgur.com/bIQ54hR.png $\endgroup$ – mrz Dec 22 '16 at 17:26
  • $\begingroup$ Yes, that is also an issue, but unfortunately I am not aware of any fixes for it yet. $\endgroup$ – lowriniak Dec 22 '16 at 17:31
  • 1
    $\begingroup$ @mrz Did you try the recommendation in the other Q&A?: SetOptions[$FrontEnd, Magnification -> 2] $\endgroup$ – Mr.Wizard Dec 22 '16 at 17:42
  • 1
    $\begingroup$ (apologies for the delayed response) I'd be happy to do the edits. @mrz to have all notebooks be set to 200% magnification go to Option Inspector, select Global Preferences, go to Notebook options, Display Options, and change the value of Magnification to 2. This means all notebooks will be at 200% by default (notice the popup at the bottom will not change, this is relative to the global value) $\endgroup$ – lowriniak Dec 23 '16 at 10:13
0
$\begingroup$

Unfortunately, as i know, there is no better solution except get a bigger screen. I met with the same issue, my solution was a 24-inch screen with 1080p resolution.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.