2
$\begingroup$

My Mathematica (v. 10.2) insists on italicizing single characters in text cells, including title cells, section cells, etc. See the "a" in "Define a rotation..." below for an example,

text cell

I've changed the notebook stylesheet (to the Mathematica Journal stylesheet) to no avail. Selecting the cell and clearing the formatting using the Classroom Assistant palette changes nothing. I'm really stumped. How do I stop Mathematica from doing this?

Edit: I found that using the button on the Classroom Assistant palette to generate a text cell gives one that behaves as I want. Here’s an example:

Cell["hello", "Text"]

But using the Alt-7 key shortcut makes a text cell like this

Cell[BoxData[ FormBox["hello", TraditionalForm]], "Text"]

which is the kind of cell that creates the problem.

Is there a way to change the Alt-7 shortcut to insert a simple text cell, as above?

$\endgroup$
  • $\begingroup$ You have changed the Cell option value for SingleLetterItalics to False and you still get this behavior? $\endgroup$ – Mr.Wizard Dec 1 '16 at 23:29
  • $\begingroup$ Please show the sourcecode that led to the errant typeface. Did you define a as a variable somewhere else? $\endgroup$ – David G. Stork Dec 1 '16 at 23:59
  • $\begingroup$ Thanks for answering so quickly. Selecting the cell and right-clicking on "properties" brings up an "options inspector" dialog. Setting SingleLetterItalics to False in that dialog fixes the problem for that cell. Selecting "Global Preferences" in the Show option values dropdown shows False, but new cells still have the option set to False. Is there a way to do this globally? $\endgroup$ – Rodney Price Dec 2 '16 at 0:06
  • $\begingroup$ @David, I get Cell[BoxData[ FormBox[ RowBox[{"Define", " ", "a", " ", "rotation"}], TraditionalForm]], "Text",.... a isn't defined anywhere else. This behavior occurs anytime I type a single letter. $\endgroup$ – Rodney Price Dec 2 '16 at 0:17
  • $\begingroup$ Why not... "Define a rotation" instead of "Define", " ", "a", " ", "rotation"? $\endgroup$ – David G. Stork Dec 2 '16 at 1:05
1
$\begingroup$

Put SingleLetterItalics->False in a stylesheet inheriting from the default style sheet. Then use an initialisation file (init.m) to load a startup notebook that sets your default style definitions.

SetOptions[$FrontEnd,DefaultStyleDefinitions->"newStylesheet.nb"]

See also How can I turn off SingleLetterItalics?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.