1
$\begingroup$

Bug introduced in 9.0 or earlier and fixed in 10.0


I tried to convolve sin with sin and got this unexpected result:

Convolve[Sin[x], Sin[x], x, y]
(* 0 *)

Now I know convolution of infinite functions is not well defined, but normalized for the length of the interval, the solution should look like $-\frac{\cos(y)}{2}$. Ignoring that, the answer should at least be $\infty$, or undefined, but definitely not zero.

Any comments, solutions, or condemnations?

(It may be worth mentioning that I am using Mathematica 9.0.1.0.
Also, WolframAlpha gives the same result.)

$\endgroup$
  • 3
    $\begingroup$ This doesn't return anything for me. $\endgroup$ – Feyre Nov 16 '16 at 18:32
  • $\begingroup$ Please do not add the bugs tag to your own questions. This is a special tag that is meant to be added by someone else than the original asker after the community verified that there is indeed a bug. When you suspect a bug, do add version information, especially if you are not using the latest version. $\endgroup$ – Szabolcs Nov 16 '16 at 18:36
  • $\begingroup$ 10.0 and later return this unevaluated. $\endgroup$ – Szabolcs Nov 16 '16 at 19:24
  • $\begingroup$ That is at least more sensible. Thanks for the info. $\endgroup$ – KDN Nov 16 '16 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.