6
$\begingroup$

Bug introduced in 10.1 or earlier and persisting through 11.0.1 or later

[CASE:3731068] It does appear that Locator is not behaving properly and can seemingly crash Mathematica's Front-end, and I have forwarded an incident report to our developers with the information you provided.


When I quickly drag the upper-right locator in this dynamic graphic

p1 = {0, 0}
p2 = {1, 1}

Dynamic@Graphics[{Arrow[{p1, p2}], Locator[Dynamic[p1]], 
   Locator[Dynamic[p2]]}, PlotRange -> 1]

all the way to the left or right boundary, my FrontEnd crashes. Can somebody reproduce this?

This is $Version "11.0.0 for Microsoft Windows (64-bit) (July 28, 2016)"

$\endgroup$
  • 1
    $\begingroup$ reproduced on V10.4, V11.0.1 Win7 $\endgroup$ – Kuba Oct 4 '16 at 18:23
  • $\begingroup$ I filed a report. $\endgroup$ – masterxilo Oct 4 '16 at 18:29
  • 1
    $\begingroup$ If you use the standard bugs header, mathematica.stackexchange.com/tags/bugs/info, there is a web app that can track the bug.... $\endgroup$ – Michael E2 Oct 4 '16 at 18:44
  • $\begingroup$ @MichaelE2 Thanks for the pointer. Where is the app? $\endgroup$ – masterxilo Oct 4 '16 at 19:01
  • $\begingroup$ There is a link to the "standard bug header" Meta Q&A in the bugs/info link above. It has a link to Pickett's app...well, to the link in chat to it. Not sure why there's so much indirection... $\endgroup$ – Michael E2 Oct 4 '16 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.