1
$\begingroup$

The behavior I am describing below may be OS specific, so I start by saying this is on Win7 x64.

I'd like to have the Special Characters palette always available, and appearing on startup. However, I want it to appear in a specific position, without any "window dressing", and I do not want it to stay on top of other Mathematica windows. So I copied the original SpecialCharacters.nb from Mathematica's installation folder to the appropriate user-specific folder, and then changed the options I needed from OptionInspector and saved the file. There's two issues now:

  1. When I set WindowFloating to False to get the desired behavior of the palette not staying on top, this has the side effect of the palette window staying open and obscuring windows of other applications when I minimize my notebook windows. That makes this option pretty much unusable. Is there a way to have the palette not stay on top of other Mma windows, but minimize along with the rest?
  2. Worse yet, the option to set WindowFloating to False seems to be ignored when the palette auto-starts: After restarting Mma I see my modified SpecialCharacters palette starting, but its window stays on top, even though I can verify in the OptionInspector that the WindowFloating option is set to False. That seems to be a bug. If I close the palette (by clicking on the "x" in the top right) and re-open it from the "Palettes" menu, the palette again behaves kind of like it should (except for 1. above, of course).

As a side remark, I would say that about 25% of the time palettes stay on top after changing the focus from Mma to some other application. The only way to get them to behave is to switch the focus to Mma again, and then back to the other application. That's another bug.

$\endgroup$
  • $\begingroup$ 1) How are you minimizing notebooks so that you want palette automatically included? Is there any way in Win do to that collectively? 2) have you saved it? 3) Do you want an answer for a specific palette or to all palettes on your system? $\endgroup$ – Kuba Sep 29 '16 at 6:24
  • $\begingroup$ 1) On Windows, Mathematica will keep the palettes open as long as there is at least one notebook open. With standard settings, it will minimize all palettes once all notebooks have been minimized. There is no way I know of to minimize a group of windows, other than to minimize the windows of all active applications. 2) You mean the offending customized palette? Yes, and I have verified that Mathematica loads this rather than the system default one (mine looks different). 3) The problem only occurs when I modify the settings of a palette so that it does not float on top of other Mma windows. $\endgroup$ – Pirx Sep 29 '16 at 10:54
  • $\begingroup$ 3. question was about whether you want tweak special characters palette or all palettes. $\endgroup$ – Kuba Sep 29 '16 at 10:56
  • $\begingroup$ Only the SpecialCharacters one. Well, at least that was my original intent. Now that you are asking and I am thinking about it, I realize that I don't feel that the behavior of palettes to stay on top of other Mathematica windows doesn't make much sense to me in any case. Thus, allowing all palettes to be obscured by other notebook windows would be fine by me. $\endgroup$ – Pirx Sep 29 '16 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.