It seems that the front end of the version 11 does not respect the AllowScriptLevelChange option when doing HTML export.

Consider the following code (call it source_1.m)

(* ::Package:: *)

SetOptions[EvaluationNotebook[], FractionBoxOptions ->
{AllowScriptLevelChange -> False}];



With Mathematica 10.3 the produced HTML looks like this

enter image description here

This is exactly what I want, i.e. the fractions are typeset properly just like they look in the front end. Now repeat the same thing with Mathematica 11

enter image description here

Apparently, this time the front end has completely ignored the AllowScriptLevelChange option and produced the standard (ugly) HTML output.

Is this a bug, or should one use some other options to change the fraction typesetting in version 11?

I'm using Mathematica and on Fedora 23 (64-bit).

  • 1
    $\begingroup$ On Win7 V11 output look like yours from V10 plus there is this black ugly frame. p.s. I'm not sure I get why it is related to the option you are mentioning, could you explain? $\endgroup$
    – Kuba
    Sep 18 '16 at 10:32
  • $\begingroup$ @Kuba Sure. The point is that I want the fractions in the HTML output to be typeset the same way as in the frontend, i.e. $\frac{a}{b}$ instead of $a/b$. The option AllowScriptLevelChange does the job. However, it looks like (at least on my system) v. 11 ignores this option and still produces the $a/b$ output that I don't like. $\endgroup$
    – vsht
    Sep 18 '16 at 10:46
  • $\begingroup$ V11, Windows here. I always get the 2d-fraction, whether or not I set that option. $\endgroup$
    – masterxilo
    Sep 18 '16 at 12:29
  • $\begingroup$ Please try SetOptions[EvaluationNotebook[], FractionBoxOptions -> {MultilineFunction -> None}] and report the result. $\endgroup$
    – Mr.Wizard
    Sep 18 '16 at 13:09
  • $\begingroup$ @Mr.Wizard Same results as with AllowScriptLevelChange, i.e. works and looks on good on 10.3 but has no effect on 11.0. $\endgroup$
    – vsht
    Sep 18 '16 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.