4
$\begingroup$

Bug present at least up to version 11.0.0

Thank you for contacting Wolfram Technical Support and for bringing this issue to our attention. Our development team is aware of the issue and working on it.


a // InputForm
b // InputForm

Gives me

enter image description here

in "11.0.0 for Microsoft Windows (64-bit) (July 28, 2016)" on my desktop and laptop computers. You can see that only the last output using InputForm is displayed. The web-app ( https://mathematica.wolframcloud.com/app ) does what I expect:

enter image description here

This only happens with InputForm, other *Forms display all outputs.

I must have some bad settings, but I cannot figure out what could be the cause. The Suggestions Bar is off and init.m is empty. Any ideas?

$\endgroup$
6
  • 1
    $\begingroup$ It is not new, (10.4 too) yet I haven't though about that! $\endgroup$
    – Kuba
    Commented Sep 12, 2016 at 17:50
  • $\begingroup$ I would consider this a bug then. $\endgroup$
    – masterxilo
    Commented Sep 12, 2016 at 17:52
  • $\begingroup$ I see. Since the web app behaves differently, I think we can finally consider this a bug/inconsistency between the two ;). What a great thing to have this second opinion. $\endgroup$
    – masterxilo
    Commented Sep 12, 2016 at 18:08
  • $\begingroup$ I filed a bug report. $\endgroup$
    – masterxilo
    Commented Sep 12, 2016 at 21:36
  • $\begingroup$ @masterxilo Any response to the report? $\endgroup$
    – Alan
    Commented Jan 19, 2018 at 18:11

0