1
$\begingroup$

There are some issues about the 11th version of MMA and this is a very strange one. For simplicity I use a simplified function:

y=x/(x^2+1)
LogLogPlot[y,{x,10^-7,1}]

It doesn't produce any results while this code works:

LogLogPlot[x/(x^2+1),{x,10^-7,1}]

I hope someone could help.

$\endgroup$
  • $\begingroup$ Use Evaluate on your first example's first argument. This is a known behaviour of the Plot family, as it has attribute HoldAll. $\endgroup$ – István Zachar Aug 30 '16 at 12:23
  • $\begingroup$ @IstvánZachar I wrote my code on MMA 10 and it worked always. I tried my code today using 11 and nothing worked. Is this normal? $\endgroup$ – yangyang Aug 30 '16 at 12:25
  • $\begingroup$ According to the docs, LogLogPlot was updated in v11, though only Callout functions are highlighted. I doubt that it didn't have a hold attribute before... Do you still have v10 to check it again? Plus, you should incorporate this discrepancy between v10 and v11 in your question before it gets closed. $\endgroup$ – István Zachar Aug 30 '16 at 12:28
  • $\begingroup$ @IstvánZachar I don't but I am planning to change back to v10 because I have a lot of code written and I cannot afford to change them all by hand. I will let you know asap. $\endgroup$ – yangyang Aug 30 '16 at 12:30
  • 1
    $\begingroup$ It is the same route cause as this even though the output is slightly different, so yes a duplicate. $\endgroup$ – rcollyer Aug 30 '16 at 12:54

Browse other questions tagged or ask your own question.