1
$\begingroup$

I have installed the Mac version of System Modeler 4 in a MacBook Pro with OS X El Capitan . Also the Coder has been installed version 7 . But the System modeler can not find the C ++ compiler not is able to choose from the Preference tab.

I am using version 7 of the Xcode. Notice that the Download tab is no longer available under the Preference and also there is no way to choose the compiler from the Verify.

Please, help me with specific instruction to add the compiler. Wolfram shows a page with a limited instructions but can not name much from it

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Have you started Xcode and agreed to the licence terms after the latest update? This is always something I forget, and has fixed problems for me before. $\endgroup$ – Marius Ladegård Meyer Aug 28 '16 at 8:45
  • 1
    $\begingroup$ Thank you.. I did,, but I found out that the problem is that I wan using version 3 and does not detect the Chang compiler. $\endgroup$ – Jose Enrique Calderon Sep 18 '16 at 3:05
1
$\begingroup$

SystemModeler 3 and it's really old and doesn't support recent versions of Xcode (you need a Xcode version that use the C++ standard library from gcc by default and not libc++).

You need to upgrade SystemModeler to at least version 4.0 for it to work with Xcode 7. Apple changed the requirements on signed applications in a patch release of El Capitan so it no longer considers SystemModeler to be correctly signed (this will be fixed in the next release). To get around it you can right-click (or ctrl + left click) on SystemModeler and select open. You should then get a dialog with an option to let it run anyway, it remembers your choice so you will only need to use this procedure once.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.