6
$\begingroup$

today i upgraded from MM 10.4.1 (which run without any problems) to MM 11.

But for me, it introduced a strange autocomplete-bug. When i try to type in "Plot" i get a huge (>5seconds) lag when i come to the second character. After that lag the autocomplete pops up (with a visible build up time [~1 second]). But it gets more strange, when i open the autocomplete for the Plot-command itself to insert the autocomplete patterns Mathematica returns a error. I made a screenshot of it: Screenshot of the occuring error

But i do not get what the error tells me. Nevertheless i tried to resolve the problem in many ways.

  • I tried to delete everything in \$UserDirectory and \$BaseUserDirectory
  • I made a soft reset
  • I reinstalled Mathematica

Another thing i noticed (what probably also could be a thing from mma11) is that the Preferences-Window takes a significant time to show up (5-10 seconds) (and prior even showing a "formatting notebook" dialog) and also operates with a noticeable lag when switching options.

Mathematica itself runs smoothly when switching the autocomplete off. (Except the Preferences-Window)

Informations about my system:

  • MMA 11.0.0 Student Edition
  • Windows 10, 64bit

Does anybody else have these issues? Was someone able to fix it? Any suggestions to fixing it?

EDIT 1: Like bbgodfrey pointed out, the problem with the error does not happen when using other commands like Solve, DSolve, Integrate, Graphics, et. work without the errors. (it has still the input lag)

$\endgroup$
  • 3
    $\begingroup$ Although I do not encounter any unexpected delays, I can reproduce the error message you obtained. The far left of your image contains PlotPlot, which you obtained when you pasted in the first choice for Plot from the drop-down menu. This is a bug. Mathematica does not behave this way, when you do the same things with, for instance, DSolve. $\endgroup$ – bbgodfrey Aug 12 '16 at 0:39
  • $\begingroup$ Hm, haven't seen this with extensive 11 usage but seems strange. I would expect deleting the two preferences directories would help with the issue... $\endgroup$ – user6014 Aug 12 '16 at 4:31
  • $\begingroup$ Strangly all issues i had disappeared over night...i dont know why or how. But everything runs fine now... Thank you for you help nevertheless. $\endgroup$ – Julien Kluge Aug 12 '16 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.