I've had the same version of Mathematica 10.4 installed for months without any problem, but this morning it is freezing every time I try to type in a notebook. New notebooks, new kernels, and existing documents all freeze after a few letters.

I have tried restarting several times, deleting configuration files, and updating to no avail. The notebook eventually starts responding after a minute or so, and allows me to type two or three more letters. Curiously, I am able to query Wolfram Alpha (and after I do so, I am able to use the Mathematica input for a few seconds), but still can't type in a new kernel. Might it be a problem with the autocomplete?

Mathematica starts using more and more memory after it freezes, increasing to about 70 or 80% before it starts responding again.

Is this a common problem? Any ideas? Happy to provide more information.

I am running Windows 10 (x64 on an AMD CPU) with 8GB of RAM.


Edit: Deleting configuration files in C:\Users...\AppData\Roaming\Mathematica worked.

  • 2
    $\begingroup$ This was likely an issue with the code completion files blowing up in size. I think WRI is aware of it and working on a fix. $\endgroup$
    – ktm
    Jul 15, 2016 at 16:22
  • 2
    $\begingroup$ Same thing is happening to me and it is still not fixed despite support from Wolfram. They have made two sets of suggestions that have not helped so far and are still working on the issue. $\endgroup$
    – Hugh
    Jul 15, 2016 at 17:15
  • $\begingroup$ I tried deleting and reinstalling Mathematically entirely to no avail. I eventually deleted the entire Mathematica folder at C:\Users\...\AppData\Roaming, and that fixed the problem. You've probably already tried that, though. Hope it gets fixed soon. $\endgroup$
    – JAustin
    Jul 15, 2016 at 18:26
  • $\begingroup$ Something similar happens to me on Mac ... but not every time ... it is intermittent. Also related to Autocomplete ...Freezes ... beach ball whirls and whirls ... and then after about 5 seconds ... it clears and I can use it again. Problem has occurred through all versions of 10.x. $\endgroup$
    – wolfies
    Jul 15, 2016 at 19:16
  • $\begingroup$ Had the same problem. Found the solution here: 109005 $\endgroup$
    – LouisB
    Jul 15, 2016 at 19:59

1 Answer 1


I had help from Wolfram on this. For Windows you have to find


Where "name" is your name. I had to work hard to find this because AppData is a hidden folder on my system.

Look to find


If it is larger than 100KB then delete it.

After that Mathematica worked fine. Apparently this is a known fault.

  • $\begingroup$ Thank you very much. It did help. $\endgroup$
    – user51528
    Aug 6, 2017 at 13:54
  • $\begingroup$ @user51528 Glad to be of assistance. $\endgroup$
    – Hugh
    Aug 6, 2017 at 15:14
  • $\begingroup$ This worked for me. The folder name was different than what was stated above, however, a search for a file with CodeAssistHistory in the file name found the file , which was 312 MB, and I was able to delete it. I had previously removed and reinstalled Mathematica but that was no help. $\endgroup$
    – joe_smith
    Dec 29, 2017 at 2:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.