3
$\begingroup$

I'm using Insert->Page Break to do just that, but thick black lines are appearing on the actual printed copy wherever I indicated a break. Can this be turned off?

$\endgroup$
8
  • $\begingroup$ What kind of printing environment do you have selected? $\endgroup$ Oct 12, 2012 at 13:46
  • $\begingroup$ @SjoerdC.deVries I'm using Bulleted Environment with Outline as the stylesheet. $\endgroup$
    – Voriki
    Oct 12, 2012 at 13:53
  • $\begingroup$ Don't know that. Are you sure you're looking at this or this? $\endgroup$ Oct 12, 2012 at 14:04
  • 1
    $\begingroup$ In the working environment page breaks appear as black lines, if I'm not mistaken. It looks like the print is emulating the working environment. I'll check what may be causing this when I'm back at my own Mathematica installation. $\endgroup$ Oct 12, 2012 at 15:40
  • 1
    $\begingroup$ I can confirm that this also happens to me in the default stylesheet. Perhaps you should contact [email protected] to make a bug report. As a workaround I suggest using cells with "\f" (form feed). Evaluate an input cell with it and copy the resulting output cell anywhere you want to have a page break. $\endgroup$ Oct 12, 2012 at 19:25

2 Answers 2

2
$\begingroup$

I can confirm that this also happens to me in the default stylesheet. Perhaps you should contact [email protected] to file a bug report. As a workaround I suggest using cells with "\f" (form feed). Evaluate an input cell with it and copy the resulting output cell anywhere you want to have a page break.

$\endgroup$
4
  • $\begingroup$ Do you mind posting the actual BoxData of the cell. I have been trying CellPrint@Cell[BoxData["\<\"\\f\"\>"], "Output"] with no luck so far. $\endgroup$
    – William
    Sep 17, 2013 at 12:23
  • 1
    $\begingroup$ @LiamWilliam I used this trick quite long ago. It must have been version 5. Indeed, it doesn't seem to work in more recent version. $\endgroup$ Sep 17, 2013 at 21:38
  • $\begingroup$ The following workaround appears to work in M9. Cell["", "Input", PageBreakBelow -> True, CellOpen->False ] $\endgroup$
    – William
    Dec 21, 2013 at 21:42
  • $\begingroup$ In addition I can't seem to repeat the original issue posted in M9 so the workaround may be irrelevant. $\endgroup$
    – William
    Dec 21, 2013 at 21:48
2
$\begingroup$

If you wish to suppress the black line you can change this in the Style Sheet. For a particular Notebook choose Format > Edit Stylesheet... and paste this into the window:

Cell[StyleData["PageBreak", "Printout"],
 Editable->False,
 CellFrame->0,
 CellMargins->{{0, 0}, {1, 1}},
 CellElementSpacings->{"CellMinHeight"->1,
 "ClosedCellHeight"->1},
 CellOpen->False,
 PageBreakBelow->True,
 CellFrameMargins->0,
 CellSize->{Inherited, 2},
 Background->None]

Choose Yes if asked "Do you want to interpret the text?". Nothing will appear because the style is invisible (that's the idea after all) but it will have effect. Close the Style Sheet.

Linebreaks in this Notebook will now be invisible in the "Printout" environment (the default for printing and PDF export).

If you want to apply this to all new Notebooks you can create a custom Style Sheet and then change the global DefaultStyleDefinitions option to point to it:

Mathematica graphics

$\endgroup$
4
  • $\begingroup$ Hey. Thank you for the answer, but the problem is still there. I've tentatively solved the problem by manually adding new lines. Not elegant, unfortunately. $\endgroup$
    – Voriki
    Oct 14, 2012 at 3:07
  • $\begingroup$ @user745434 when using the method presented to you still see the black dividing lines on the screen in Screen Environment > Printout, or only on paper? $\endgroup$
    – Mr.Wizard
    Oct 14, 2012 at 3:22
  • $\begingroup$ only on paper. Just now I realized that printout is also a screen environment (sorry, new guy). I was referring to the paper itself (also print preview, saved PDFs, etc.) $\endgroup$
    – Voriki
    Oct 14, 2012 at 3:45
  • $\begingroup$ @user okay, I haven't tried printing to paper. I'll see if I can find a solution that affects that too but it will have to wait. $\endgroup$
    – Mr.Wizard
    Oct 14, 2012 at 4:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.