10
$\begingroup$

Bug introduced in 10.4 and fixed in 11.0


I am running Mathematica 10.4.1.0 on a MacBook Pro OSX 10.11.5. I opened the documentation for TransformedRegion, went to this example in Scope > Formula Regions. When I open this particular documentation, the image is present, but when I ran these two lines:

pr = ParametricRegion[{Sin[θ], Sin[2 θ]}, {{θ, 0, 2 π}}]
RegionPlot[pr]

I got a blank image:

enter image description here

I've tried quitting the kernel and I've tried restarting Mathematica, but it still doesn't work.

Anyone else experiencing this?

$\endgroup$
9
  • 3
    $\begingroup$ Yep, same here on Windows. Also the first basic example for ParametricRegion fails. $\endgroup$ Commented Jun 26, 2016 at 21:08
  • 2
    $\begingroup$ I seem to have the same problem. The example given in Mathematica help ParametricRegion[{Cos[t], Sin[t]}, {{t, 0, 2 Pi}}]] also fails (Mathematica 10.4.1, 64-bit Linux) $\endgroup$
    – mikado
    Commented Jun 26, 2016 at 21:09
  • 3
    $\begingroup$ Curiously it works if I replace 2 Pi with 6.28 $\endgroup$ Commented Jun 26, 2016 at 21:12
  • 2
    $\begingroup$ OK. I'll report this to Wolfram. $\endgroup$
    – David
    Commented Jun 26, 2016 at 21:30
  • 1
    $\begingroup$ and works with 1.9999999 Pi ... $\endgroup$
    – Young
    Commented Jun 26, 2016 at 21:37

1 Answer 1

1
$\begingroup$

As noted, this is fixed. Here it is on 11.0.1.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.