2
$\begingroup$

Bug introduced in 9.0 and fixed in 9.0.1


I think I am experiencing the same/similar problems as this user.

Mathematica Version: 9.0 for Mac OS X x86 (64-bit) (November 20, 2012)

Computer: Mac OS X 10.11.5

When I run the code below, LisPolarPlot works fine until I include the option PolarAxes->True at which point it spits out reams of error messages. Any advice on solving this issue or implementing an alternative to achieve similar results?

list = Table[{t, Sin[t]}, {t, 0, Pi, 0.1}];
ListPolarPlot[list, PolarAxes -> False]
ListPolarPlot[list, PolarAxes -> True]

enter image description here

$\endgroup$
  • 1
    $\begingroup$ For reference, what version and OS are you on? $\endgroup$ – J. M. will be back soon Jun 16 '16 at 13:44
  • $\begingroup$ Good point. Updated question. $\endgroup$ – Tom Jun 16 '16 at 13:47
  • $\begingroup$ MMA 9.0.1.0 in Ubuntu 12.04 64bit - no error :) $\endgroup$ – Sumit Jun 16 '16 at 13:52
  • 2
    $\begingroup$ Regardless of whether or not I can reproduce it on 9.0.0, or not, I can't reproduce it on later releases, nor can I reproduce it on 8.0.1. So, it seems isolated to a narrow set of builds. So, if possible, upgrade. $\endgroup$ – rcollyer Jun 16 '16 at 14:05
  • 1
    $\begingroup$ Can confirm this bug in version 9.0.0.0 - @rcollyer is the upgrade to 9.0.2 free? If so that seems easier than hunting down a workaround $\endgroup$ – Jason B. Jun 16 '16 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.