1
$\begingroup$

Following is my form function:

addressForm = FormFunction[{
   "StreetAddress" -> "String",
   "City" -> "String",
   "State" -> "String",
   "ZIPCode" -> "Number"
   }, addressCallback[#StreetAddress, #City, #State, #ZIPCode] &]

and the function that applies to the input:

addressCallback[StreetAddress_, City_, State_, ZIPCode_] :=

 Module[
   {ste = StringTrim[ToString[StreetAddress]], 
    ctt = StringTrim[ToString[City]], 
    stt = StringTrim[ToString[State]], 
    zip = StringTrim[ToString[ZIPCode]]},
   Return[ste <> 
     If[StringDrop[ste, StringLength[ste] - 1] == ",", "", ","] <> 
     " " <> ctt <> ", " <> stt <> "-" <> zip]
   ]

I see some output in the message console (error, which is weird) and when I deploy it online with

CloudDeploy[addressForm, Permissions -> "Public"]

there is no output after form submission, just a blank page. Kindly help me.

$\endgroup$
  • $\begingroup$ Your code seems to work as intended (?) locally. For instance, I get the following output after running your code and putting in some made-up values: result (the result does appear in the main notebook, not in the message console). I didn't deploy it, so I don't know about that part. $\endgroup$ – MarcoB Jun 9 '16 at 21:16
  • $\begingroup$ Works well on cloud too. What's your $CloudCreditsAvailable? $\endgroup$ – Kuba Jun 10 '16 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.