1
$\begingroup$

I am just starting with Mathematica and I have tried to solve PDE following DSolve, with first three inputs from the Elliptical Partial Differential equations section:

leqn = Laplacian[u[x, y], {x, y}] == 0;
bc = u[x, 0] == UnitBox[x];
sol = DSolve[{leqn, bc}, u[x, y], {x, y}]

But instead analytic form in the link I have only an echo

DSolve[{Derivative[0, 2][u][x, y] + Derivative[2, 0][u][x, y] == 0, u[x, 0] == UnitBox[x]}, u[x, y], {x, y}]

I am using Mathematica 10.0 Student Edition. Could anybody give me an advice? Thank you.

Sorry for that question, I know that similar topics were discussed here. But I have expected, that the program should work correctly at least for inputs from the tutorial.

$\endgroup$
7
  • $\begingroup$ On MMA 10.4 I obtain the output indicated in the docs: result. Just to make sure that it is not something simple, have you tried restarting Mathematica and running the code again? If that doesn't work, maybe you should get in touch with Wolfram Support. $\endgroup$
    – MarcoB
    Apr 15 '16 at 13:40
  • $\begingroup$ Thank you. Yes, I have tried restarting Mathemataica, but it did not help. $\endgroup$
    – user
    Apr 15 '16 at 13:43
  • $\begingroup$ I am not quite sure, but it seems that analytical solution of partial differential equations are only since 10.3, if not 10.4 $\endgroup$ Apr 15 '16 at 13:43
  • 3
    $\begingroup$ I knew there was a reason to keep all these old versions on my hard drive. I can confirm it works for versions 10.3 and after, but not for prior versions. $\endgroup$
    – Jason B.
    Apr 15 '16 at 14:00
  • 4
    $\begingroup$ I'm voting to close this question as off-topic because the OP is asking for a capability that does not exist in the version of Mathematica the OP is using. $\endgroup$
    – m_goldberg
    Apr 15 '16 at 16:20