1
$\begingroup$

In my notebook's private style sheet, I set the style for Text to

Cell[StyleData["Text"],  Hyphenation->False,  ParagraphIndent->0, 
TabSpacings->{2.9},  FontSize->12]

because I encounter too many mal-hyphenated words in German text (btw: is there a spelling check including hyphenation for non-English text?).

I applied Shift-Ctrl-E again to the Text-prototype cell but text cells in the notebook which I had written before did not inherit this property from the changed style sheet, as I fond out when I checked one cell with automatic but wrong hyphenation.

Even a new Text cell which I create after changing of Text Cell's properties in the notebook's style sheet appear as type Cell["", "Text"], i.e. they inherit nothing from my modified prototype.

What's wrong here?

How do I let all styles definitions from the notebook's style sheet apply to all cells with matching type in the notebook?

$\endgroup$
  • $\begingroup$ Hyphenation is a little bit hard to test, especially in languages that do not use long words (and it is not a interesting problem). As it seams that you have the same problem with the other parameters, for example FontSize, I have played with FontSize and it works perfectly. I don't understand where is the problem. $\endgroup$ – andre314 Mar 18 '16 at 20:20
  • $\begingroup$ What did you do with FontSize? I also played with FontSize before but it looks like FontSize is not the entity we know from Word or LibreOffice: FontSize->12 looks like 8 point on the screen, good advertizing for eyeglass makers! Even if in OptionsInspector SelectedNotebook>DisplayOptions>Magnification is 1.0. I even encountered that Magnification on rhe right bottom of my notebook shows 150% and OptionInspector shows 1.25! $\endgroup$ – Adalbert Hanßen Mar 21 '16 at 15:16
1
$\begingroup$

In order to switch off Hyphenation e.g. for all Text cells, execute the command

SetOptions[#, Hyphenation -> False] & /@ 
  Cells[EvaluationNotebook[], CellStyle -> "Text"];

in the notebook. Bingo!

(WRI told me that Hyphenation is a Cell option rather than a Notebook option and together with that answer they gave me this workaround.)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.