23
$\begingroup$

My front-end freezes as soon as I type more than two letters in a notebook. I think the error occurs, when the auto-complete feature kicks in. If Mathematica was started from a terminal, the following text is shown.

Mathematica has received the signal: SIGSEGV and has exited.
If possible, please report this problem to support@wolfram.com
describing in as much detail as possible what you were doing
when the problem occurred.

I use Mathematica 10.3 on Ubuntu 12.04. Rebooting and -cleanstart did not help. This installation worked fine for quite some time, but suddenly this problem appeared.

Is this a known problem? Before I contact the official support, I want to make sure that there is no trivial fix.

$\endgroup$
  • 2
    $\begingroup$ @StefanR You were right, CodeAssistHistory10.3.m was 321MB big! Removed it, everything works. Thanks! $\endgroup$ – murphy Mar 3 '16 at 19:25
  • $\begingroup$ @murphy good to hear! Sorry you ran into this! $\endgroup$ – Stefan R Mar 3 '16 at 19:27
  • $\begingroup$ @StefanR Maybe you should add your comment as an answer. That would make it more future-proof and I could close the question. $\endgroup$ – murphy Mar 5 '16 at 11:42
  • 2
    $\begingroup$ I have just noted a similar behavior on 10.4 (Win 10 Pro), where all text inputs after two characters suddenly stopped as can bee seen in this capture of the problem. Unfortunately I was pointed to this post too late - I am just reinstalling Mathematica... $\endgroup$ – gwr Apr 18 '16 at 17:51
  • $\begingroup$ See also this post asking for bug reports including the CodeAssistHistory files for better diagnostics of this problem and hopefully a fix in the future. $\endgroup$ – Emilio Pisanty Apr 24 '16 at 18:17
25
$\begingroup$

(Posting my comment as an answer, per @murphy's suggestion)

Please check the folder

$UserBaseDirectory/SystemFiles/FrontEnd/SystemResources/Functional‌​Frequency

and see if there are any unusually large files there (>100 Kb or so). If any such files exist, please delete them. The file CodeAssistHistory10.3.m is often the culprit, and is safe to delete.

$\endgroup$
  • $\begingroup$ Are there plans to fix this? My CodeAssistHistory10.4.m is also huge (25.2 MB), and most of it is just a bunch of ÂÃÂÃ... $\endgroup$ – QuantumDot Apr 14 '16 at 13:07
  • 7
    $\begingroup$ @QuantumDot we believe we have a fix for this in Mathematica 10.4.1. $\endgroup$ – Stefan R Apr 15 '16 at 16:52
  • 2
    $\begingroup$ I can confirm that this solution works with regard to my above comment. My CodeAssistHistory10.4m had a size of 712 MB at the time of deletion. $\endgroup$ – gwr Apr 18 '16 at 18:58
  • $\begingroup$ Thanks a lot for this! My file was 1.5GB in size at the time of deletion! $\endgroup$ – Prahar May 12 '16 at 20:24
  • 1
    $\begingroup$ This didn't work for me. I didn't have any files of the form Code* in my FunctionalFrequency folder, and none of the files were over 18 MB. I deleted all the ones over 100 KB but the problem still persists if I enable autocomplete. $\endgroup$ – tparker May 17 '16 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.