1
$\begingroup$

I want to Make a list of large cities in Germany

 CityData[{Large, "Germany"}]

enter image description here

but in Documentation Center answer is in short form

enter image description here

How to get the answer like this?

Sorry for my English. Thanks!

$\endgroup$
8
  • $\begingroup$ Does this still happen after restarting Mathematica? What version and OS are you on? $\endgroup$ Commented Feb 27, 2016 at 10:00
  • $\begingroup$ @J.M. yes it still happen after restarting. I have a windows 10. and Mathematica 10 . $\endgroup$
    – vito
    Commented Feb 27, 2016 at 10:06
  • 2
    $\begingroup$ Did you make any changes to your init.m, or did you change any settings before? Does this happen for other Entity[] objects (e.g. the examples in the docs)? $\endgroup$ Commented Feb 27, 2016 at 10:26
  • $\begingroup$ Check that it is the latest version of Mathematica 10.3.1 . There was a bug regarding the connection to Wolfram Research Data center in earlier versions of 10. $\endgroup$
    – FredrikD
    Commented Feb 27, 2016 at 10:34
  • 1
    $\begingroup$ You need to set or convert cell style to StandardForm. $\endgroup$
    – Bob Hanlon
    Commented Feb 27, 2016 at 14:40

2 Answers 2

1
$\begingroup$
cities = FullForm[CityData[{Large, "Germany"}]]
$\endgroup$
2
  • 3
    $\begingroup$ That will generate the output depicted in the first picture. OP seems to want the output in the second picture. $\endgroup$ Commented Feb 27, 2016 at 13:28
  • $\begingroup$ You can format inline code and code blocks by selecting the code and clicking the {} button above the edit window. The edit window help button ? is also useful for learning how to format your questions and answers. You may also find this this meta Q&A helpful $\endgroup$
    – Michael E2
    Commented Feb 27, 2016 at 13:45
1
$\begingroup$

Maybe you should go to Preference->Evaluation and make sure the setting of Format type of new output cells is StandardForm as follows:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.