4
$\begingroup$

So I like using Mathematica for quickly typing up notes and progress reports. However, I've never liked the way in which it autoformats inline cells. I've been able to modify style sheets to some extent but there are two major issues with inline cell formatting that I haven't found an adequate solution for, (1) the automatic kerning adjustment (adding extra space) after subscripts/superscripts, this is primarily a problem when I am typing out a chemical formulas, (2) auto italicizing single letters. Here's an example of the problem

Any suggestions would be much appreciated.

$\endgroup$
  • $\begingroup$ This might help you: After you are out of the inline cell, triple click it in order to select it and then press CTRL-Shift-N in order to convert it to StandardForm. $\endgroup$ – Gustavo Delfino Feb 25 '16 at 20:50
5
$\begingroup$

Use Insert > Typesetting > Nudge Left. This creates an adjustment box. If this is a regular thing you can create a past button or similar to paste your preset template with all the adjustment boxes in place. To avoid italics you can set SingleLetterItalics to False in the options inspector.

enter image description here

| improve this answer | |
$\endgroup$
  • 2
    $\begingroup$ Excellent, this works pretty well! I was unaware of SingleLetterItalics, but now it's set to false in my stylesheet of choice, so that problem is solved. The nudge left it hot keyed so it's pretty quick (though I had to turn off Crtl+"Left" on OS X which is fine becaus eId on't use it), but still a little inconvenient. It seems as though sub/superscripts are formatted such that the box size remains the same as text, but the character is decreased in size and the alignment is shifted. I wonder if there is a way to change the default box size of the sub/superscripts. Thanks again! $\endgroup$ – Alex Mohamed Feb 25 '16 at 21:51
  • $\begingroup$ (+1) Nice answer. :) Is there anyway to put the style of inline formulas like the display formulas? :) $\endgroup$ – Hosein Rahnama Jul 26 '16 at 9:59
  • 1
    $\begingroup$ @H.R. you could create a style sheet in which the inline styles are the same as the display formula styles $\endgroup$ – Mike Honeychurch Aug 3 '16 at 11:32
3
$\begingroup$

The spacing the OP is seeing is because the inline cell is being interpreted as a product, and so there is space between each element in the product. Setting ZeroWidthTimes -> True in addition to SingleLetterItalics -> False will fix both of the issues noted by the OP.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.