2
$\begingroup$

This happens with Mathermatica 10.3.1.0:

When working with a notebook, I can choose between different working environments. However, they inherit their settings from Default.nb situated at

c:\Program Files\Wolfram Research\Mathematica\10.3\SystemFiles\FrontEnd\StyleSheets\Default.nb

on my Windows7 computer. In Default.nb the local definition for all styles in environment printout has Magnification->0.72 which yields printouts with too small characters (compared to the line length). Therefore my printed notebooks are not reader-friendly.

Also I use some text cells with hanging indentation, e.g. ParagraphIndent->-80, TabSpacings->{4.4}. I begin those cells with a number or with a keyword, then a tab and then the rest of the text. Then the rest is indented by 80 printer points with respect to the beginning of the outdented keyword or number. The tab position is in those not well understood ems units. I just figured out that the combination of ParagraphIndent -80 and TabSpacings 4.4 looks good on the screen as long as I stay with Magnification->1.25, my favourite setting with the sreen I use. However, if I switch notebook magnification to something else, my carefully made indentation gets out of order (but it restores itself, as soon as I return to magnification 1).

If I print my notebook the carefully chosen indentation gets out of order on the printout. To my understanding this is due to the implicit change of magnification to environment printout.

Therefore I want to change the setting in

changing magnification for Printout

and I hit Shift-Ctl-E:

ShowExpression of it

and want to change the setting from 0.72 to 1.0. However, I only can mark the entry, but I am unable to change it! If I type a number, it won't!

I try it using OptionInspector for the cell:

the same situation in OptionsInspector

I can't change the number! This even happens, if I try to do all this on a copy of Default.nb in c:\temp, where I definitely have writing rights.

What's wrong?

$\endgroup$
1
$\begingroup$

in the top corner of the cell bracket you will see a strange pattern which actually means that the cell is not editable. You can confirm this by clicking on the cell bracket and then going to the options inspector and looking up editable. You should not edit the default or core stylesheets. Create your own stylesheets as per several examples here and modify the magnification on the Printout style.

$\endgroup$
0
$\begingroup$

Like Mike says, you can't edit the default or core stylesheets (or at least you shouldn't).

Try this: open your notebook and go to Format->Edit Stylesheet... and type in:

CellPrint[Cell[StyleData[All,"Printout"],Magnification->1.0]] Magnification in Style Definitions This should change the magnification to 1.0 (or whatever number you enter).

Hope this helps!

$\endgroup$
  • $\begingroup$ Yet you can always copy it to $UserBaseDirectory: mathematica.stackexchange.com/a/81016/5478 $\endgroup$ – Kuba Sep 10 '16 at 10:54
  • $\begingroup$ I also found that the default stylesheet can not be directly edited, even though it still has a statement in it saying you can. So I changed it in the personal stylesheet instead, and it still didn't work! Even though the "Printout" string changed magnification in the Printout environment entry. Trying to change printout mags (for "Printout" and "Working") through the Option Inspector also did not work. Have logged a bug report with Wolfram stating that nothing seems to change printout magnifications for MMA 11.0.1 Home running on my Windows-64 PC. $\endgroup$ – Bill N Dec 6 '16 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.