2
$\begingroup$

I have written a notebook but in order to edit it, I prefer 125% magification or even 150%.

I know Window>Magnification. Also there is a small symbol on the right bottom of the notebook, where I can influence this setting:magnification icon

However, on this particular notebook (with quite some editing work in it!)

  • changing the magnification takes a considerable amount of time,
  • sometimes, Word even shows "keine Rückmeldung" when setting the magnification to 125%
  • sometimes Mma switches to an even lower maginification than 100% automaticly (I could not figure out, when this happens),
  • and I even encountered a case, when I wanted to increase the magnification but ended up with a smaller one!

What might be the reason for those quirks?

P.S.: I just moved a picture which I had pasted into a notebook cell together with the enclosing cell to another place in the same notebook. Then over a sudden, the magnification switched from 125% to 90%. And 90% is not one of the magnifications offered from the list (I know, you might use OptionsInspector to set it to any value).

Why this strange value? Why the change at all?

P.S.: after this has happened, the quirky behaviour of the front end is back where it takes very long to change the magnification. It looks like moving the cell with the pasted picture reproducably sends the Mathematica session into "keine Rückmeldung" on the Windows-level.

PP.S.: The graphics moved in the trial before did not fit on the whole screen. Even with 100% magnification it was a bit higher. I tried the operation again at 75% magnification. Then it fitted on the screen. Then the movement of the cell worked without sending Mathematica into the quirky behaviour. After this modification, I could change the magnification and that worked almost instantaneously.

PPP.S.: However, it all happened with ShowPageBreaks->On on my first and second trial. On the third one, I had ShowPageBreaks->Off. After switching it On again in order to check, if after moving the picture, page breaks are in meaningful places. The Mathematica-session gets stuck again with ShowPageBreaks->On: "Keine Rückmeldung".

PPPP.S.: After killing the session and starting it over again, I switched ShowPageBreak on but rather than showing me the grey lines of the page breaks, it just reduced the magnification. Toggeling the ShowPageBreak-state however makes changing the magnification back to 125% very sluggish. First I even suspected the session being inaccessible.

$\endgroup$
  • 2
    $\begingroup$ just a note about the "magical" changes of magnifications: you can change the magnification with Ctrl+Mouswheel, in steps of 10%. While that sometimes is quite handy, it unfortunately is easy to do that without even noticing (e.g. during copy+paste). I would guess that at least some of the cases where you saw the magnification to change unexpecedly might be due to that feature... $\endgroup$ – Albert Retey Feb 4 '16 at 22:55
1
$\begingroup$

To set the default magnification for a notebook:

Preferences -> Advanced -> Notebook Options -> Display Options -> Magnification

then double click slowly on the "value" until it highlights blue and then you can type a default value corresponding to 100%

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.