4
$\begingroup$

As far as I remember, on a Windows PC in the old days of Mathematica 4 I could paste an image from the clipboard by just pressing Ctl-V. This seems to be no longer available on my Linux PC.

If I try it now in Mathematica 10.1 under Linux through the menu (Insert>Picture), I miss an option "paste from clipboard":

possible choices of insert drop down list

Is there a way to add the missing feature "paste Graphics from clipboard"? (e.g. by modifying /usr/local/Wolfram/Mathematica/10.1/SystemFiles/FrontEnd/TextResources/X/MenuSetup.tr).

P.S.: On a Windows PC, one can paste an image from the clipboard by just Ctl-V with Mma10.3.

The reason to rise the question was that I wanted to digitize points in a graphics pasted into a Mma notebook. This was definitely possible in Version 4.0.

On the windows version with Mma10.3, you can paste the graphics directly from the clipboard, but you can not digitize points by holding down Ctl and click into the picture at the points you want to digitize. However sometimes one can invoke a "Coordinate Tool" (the fourth choice after left clicking onto the pasted Graphics). On the first trial this was available (it was just a screenshot from Mma which I just had on the clipboard):

pasted graphics with choice of coordinate tool

on the next trial with a picture from which I wanted to determine some distortion coefficients, I did not get that choice:

Picture to digitize items

I do not see any reason, why I get a crossed arrow then and can just move the whole picture on the screen and I do not get the choice of my first example, in which you can see the colour values of pixels, mark the pixels and finally you can use CopyCoordinates from the drop down menu Copy. After this the points can be pasted from the clipboard and can be pasted into a Mma cell, e.g. to make an affine transformation on the digitized graphics before further evaluation.

What is the difference in my second example?

$\endgroup$
  • $\begingroup$ It is Edit -> Paste, not Insert -> Picture. I just tried copying an image from a web browser and pasting it using Edit -> Paste (on Linux, Ubuntu) and it worked fine with M10.3. $\endgroup$ – Szabolcs Feb 2 '16 at 21:21
  • $\begingroup$ I also can't reproduce this, when I right-click on one of the images in this question and select "Copy Image" and then go to the notebook and hit Ctrl-V I get the image (I'm using version 10.3.0 Linux). However, there are definite problems with pasting in Linux, as brought up here $\endgroup$ – Jason B. Feb 3 '16 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.