6
$\begingroup$

I have installed Mathematica 10.3 on Windows 10 Pro, x64 machine, and now I am trying to install Wolfram Workbench plugin.

I have read all the posts related to this type of error, most notably "error trying to open a notebook in wolfram workbench" and "how to install the wolfram workbench plugin into eclipse kepler".

I can verify that this last solution works on Windows 7 with a 32bit version of Eclipse Kepler and Java x86 version. I have not managed to find any combination of Eclipse, Java and Wolfram Workbench plugin to make this work in Windows 10.

I have tried with zipped installations of Wolfram Workbench, they include Java x86 and the plugin. Then I tried with both 32bit version of Eclipse MARS and Eclipse HELIOS SDK 3.6.2 using x86 jre 1.8.0_66 and I have followed instructions on how to install new software in Eclipse.

When you finish with this part, then you have to change Wolfram Workbench Mathematica path so that it finds the executable. But when you double-click on a notebook from inside a Wolfram Workbench project you get the following error message:

FrontEnd Job:: Open Notebook has enountered a problem. An internal error occurred during::FrontEnd Job::Open Notebook.

Details: an internal error occurred during: "FrontEnd Job::Open Notebook". com.wolfram.jlink.NativeLink.MLOpenString(Ljava/lang/String;[Ljava/lang/String;)J

Postings on this site suggest that 32-bit is the only workable solution, but someone mentioned that there is a workaround for 64-bit machines. Is that possible ? I could not find the details of such a solution.

Moreover the Q&A I have read in other posts are full of comments and the reader becomes easily frustrated on what really works. Therefore please try to be as pedantic as possible when you post your answer here. In particular I would like to see

  • OS: Windows 10
  • Mathematica Version : >10.2
  • Eclipse Version x86? :
  • Java Version x86? :

And details on the procedure you followed to install Indigo and Wolfram WorkBench. I am bit suspicious that I am doing something wrong in that part.

I am aware that the problem I am reporting here is well known, but see this as an opportunity to summarize on Wolfram Workbench installation experience other users had and on installing this eclipse plugin on machines that have the latest and greatest Windows 10 - Mathematica 10>.

$\endgroup$
  • 1
    $\begingroup$ Install mm 9 first, it works then. Given the importance of workbench for complex projects i hope this issue will be fixed one day. mathematica.stackexchange.com/q/69567/66 $\endgroup$ – faysou Jan 8 '16 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.