4
$\begingroup$

When I launch Mathematica and write the first command and press Return+Shift, whatever the command is, it takes forever to evaluate — about two minutes. Immediately after the first evaluation (even if I abort it) everything is back to normal.

If I then restart the kernel, the problem does not come back.

If I just wait for a couple of minutes after the start-up, the problem also does not appear.

From these observations, I would conclude that this problem is not related to the kernel (though I'm not a programmer).

I've been seeing this behavior since upgrading to 10.3 and it persists in 10.3.1.

Is this a bug? Is it Mac-only? Is it known?

$\endgroup$
  • $\begingroup$ What are the stats of you computer? RAM? processor? etc? $\endgroup$ – rcollyer Jan 4 '16 at 22:32
  • $\begingroup$ @rcollyer 2 GHz Intel Core i7, 8 GB 1600 MHz DDR3, Intel HD Graphics 4000, SSD memory. Mac OS X 10.11.2 $\endgroup$ – level1807 Jan 4 '16 at 22:33
  • $\begingroup$ It might be helpful to check the activity monitor (search for via spotlight) while the issue occurs to see if there is high load on the CPU or RAM $\endgroup$ – Sascha Jan 4 '16 at 23:22
  • $\begingroup$ @Sascha no, almost nothing is happening — 3-4% load from Mathematica. $\endgroup$ – level1807 Jan 5 '16 at 0:01
  • $\begingroup$ I have never experienced this problem on my Mac with Mathematica 10.3.1 or earlier. MacBook Pro: Processor 3 GHz Intel Core i7; Memory 16 GB 1600 MHz DDR3, 1 TB SSD; Graphics Intel Iris 1536 MB; OS X 10.11.2 $\endgroup$ – Bob Hanlon Jan 5 '16 at 0:41
4
$\begingroup$

I got the same problem and solved it by doing this. Just go to the Preferences->Internet Connectivity and turn off Allow the Wolfram System to access the Internet, then relaunch Mathematica.

$\endgroup$
  • $\begingroup$ Thanks for this solution. Of course, with this setting WolframAlpha doesn't work. It is pretty frustrating that this bug persists in 10.4. $\endgroup$ – level1807 Mar 4 '16 at 1:49
3
$\begingroup$

First, try resetting Mathematica by following this article:

http://support.wolfram.com/kb/12464

Even if there's no reason why it should work, please try it.


If that doesn't work, then try running the Mathematica kernel:

http://support.wolfram.com/kb/12414

You should be able to evaluate simple things like 2+2. Can you? If not, are there error messages? Try to evaluate:

SystemInformation["Small"]

Does that work? What is the output?


If none of this works, you may want to contact Wolfram Technical Support by email using this form:

http://www.wolfram.com/support/contact/email/?topic=Technical

$\endgroup$
  • $\begingroup$ Resetting didn't do anything. It does evaluate everything, but only after a couple minutes since the start-up pass (or if I start and abort the first evaluation). $\endgroup$ – level1807 Jan 5 '16 at 21:45
1
$\begingroup$

This annoying bug has finally been fixed in 11.0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.