5
$\begingroup$

In the output of a code I can view that the same axe has two names "z" and "x".

How could I correct this?

The code is

 ParametricPlot3D[{0*v, 0*v, 0*v}, {v, 0, 1}, PlotRange -> {-9, 9}, 
 PerformanceGoal -> "Quality", 
 PlotStyle -> {Directive[Yellow, Opacity[0.74]]},
 AxesLabel -> {"x", "y", "z"}, LabelStyle -> {20, Bold}, 
 ImageSize -> Large, ViewPoint -> {11, 2, 3}, Boxed -> False, 
 AxesOrigin -> {0, 0, 0}]

enter image description here

I think a solution to clarify the image is put the names of axis in the extreme of the axis. If the trouble is because the proximity of the names of axis.

$\endgroup$
  • $\begingroup$ The problem is that axis labels for 3D graphics are placed near the centre of the axis. In fact in your plot the axis running from left to right that "z" and "x" both appear to be sitting on, is the y axis. You can see this by adding AxesStyle -> {Red,Green,Blue} to the options. $\endgroup$ – Simon Woods Dec 23 '15 at 11:53
  • $\begingroup$ ok, @SimonWoods I found one solution, with no labels and adding inside a multiple graph Graphics3D[Text[Style["x", 18, Bold], {rtop*0.88, 0, 0}]], Graphics3D[Text[Style["y", 18, Bold], {0, rtop*0.88, 0}]], Graphics3D[Text[Style["z", 18, Bold], {0, 0, rtop*0.88}]], $\endgroup$ – Mika Ike Dec 23 '15 at 11:55
  • $\begingroup$ same problem : stackoverflow.com/a/6185820 $\endgroup$ – andre314 Dec 24 '15 at 22:00
  • $\begingroup$ related : mathematica.stackexchange.com/q/26979/5467 $\endgroup$ – andre314 Dec 24 '15 at 22:13
4
$\begingroup$

I would use Show and put the labels as separate graphics:

m = 9; (*plot range*)
labels = {Text[Style["X", 16], {1.2 m, 0, 0}], 
  Text[Style["Y", 16], {0, 1.2 m, 0}], Text[Style["Z", 16], {0, 0, 1.2 m}]};

Show[
 ParametricPlot3D[{0*v, 0*v, 0*v}, {v, 0, 1},
  PlotRange -> {-m, m},
  PerformanceGoal -> "Quality",
  PlotStyle -> {Directive[Yellow, Opacity[0.74]]},
  AxesLabel -> None,
  LabelStyle -> {20, Bold},
  ImageSize -> Large,
  ViewPoint -> {11, 2, 3},
  Boxed -> False,
  PreserveImageOptions -> False,
  AxesOrigin -> {0, 0, 0}],
 Graphics3D[labels]
 ]

Mathematica graphics

$\endgroup$
4
$\begingroup$
ParametricPlot3D[{}, {v, 0, 1},
 AxesOrigin -> {0, 0, 0},
 BaseStyle -> {Gray, 20, Bold},
 Boxed -> False,
 Epilog -> {Text["X", {.95, .5}], Text["Y", {0.4, 0.35}], Text["Z", {.5, .95}],},
 ImageSize -> Large,
 PlotRange -> {-9, 9},
 ViewPoint -> {11, 2, 3}]

enter image description here

$\endgroup$
0
$\begingroup$

The problem is with your ViewPoint. Here I use ViewPoint -> {5, 10, 4}

enter image description here

To be safe, you can avoid the Viewpoint. Plot it, then rotate it to get the best view, and then use File>Save Selection As or Right click > Save Graphic As to save the image.

$\endgroup$
0
$\begingroup$

I found one solution, with no labels and adding inside a multiple graph

Show[ParametricPlot3D[{0*v, 0*v, 0*v}, {v, 0, 1}, 
  PlotRange -> {-9, 9}, PerformanceGoal -> "Quality", 
  PlotStyle -> {Directive[Yellow, Opacity[0.74]]},
  AxesLabel -> {"x", "y", "z"}, LabelStyle -> {20, Bold}, 
  ImageSize -> Large, ViewPoint -> {11, 2, 3}, Boxed -> False, 
  AxesOrigin -> {0, 0, 0}]
 , Graphics3D[Text[Style["x", 18, Bold], {rtop*0.88, 0, 0}]], 
 Graphics3D[Text[Style["y", 18, Bold], {0, rtop*0.88, 0}]], 
 Graphics3D[Text[Style["z", 18, Bold], {0, 0, rtop*0.88}]]]

enter image description here

$\endgroup$
  • $\begingroup$ I think you would want to drop the AxesLabel so as to avoid duplicate labels. $\endgroup$ – Jack LaVigne Dec 24 '15 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.