Since version 10, if I type e.g. an RGBColor or simply a named color, a dynamic colour swatch is returned.


Same goes for when you e.g. extract colours from a plot (in this case called p).


I'm wondering if there is a simple option that I have overlooked to turn this behaviour off. I've had a look through the Options Inspector and system options but there was not anything obvious.


Just to be clear, my preferred solution is to have RGBColor[1,0,0] returned or alternatively the swatch without the tooltip and dynamics (just the Graphics[…])

  • 2
    $\begingroup$ One way is to clear FormatValues[RGBColor] =. after unprotecting it. I'm really wondering whether anyone uses these swatches. I hate them. It's as useful as having img=.. and then a big inline image on the right side. Awful. $\endgroup$
    – halirutan
    Dec 19, 2015 at 8:25
  • $\begingroup$ @halirutan On the contrary, I use them a LOT! I find them more concise and more informative than a triplet of RGB numerals. Though I'm quite good in reading those, swatches save some extra shift-entering for me. It obviously fits in the symbolic nature of Mathematica. And of course one always can use FullForm on them. $\endgroup$ Dec 20, 2015 at 10:41
  • $\begingroup$ @halirutan I use them to colour code the probabilities from classifications but don't want tooltips and for them to be clickable with a colour selection window appearing. In other words for app building it is very annoying. $\endgroup$ Dec 20, 2015 at 22:33

2 Answers 2


This should work:

SetSystemOptions["TypesetOptions" -> "ColorDirectiveSwatches" -> False]
  • $\begingroup$ Thanks Simon. I suspected that there had to be a system option for that $\endgroup$ Dec 19, 2015 at 21:29

You can disable this interactivity (and keep the swatches) with the Deploy function.

yields a deployed version of expr in which elements such as Slider, InputField, Locator and Button are active, but general editing and selection is disabled.


Hope this helps.

  • $\begingroup$ Have you tried it yourself? It does not work for me (tested with versions 10.2 and 10.3.1 on Win7 x64). $\endgroup$ Dec 19, 2015 at 14:36
  • $\begingroup$ @AlexeyPopkov Of course I've tried it. Works fine for 10.3.1 and 10.2 on Win 8.1 Pro 64bit. I use Deploy all the time. $\endgroup$
    – Edmund
    Dec 19, 2015 at 14:43
  • $\begingroup$ Very strange, here is what I get: screenshot. $\endgroup$ Dec 19, 2015 at 15:25
  • 2
    $\begingroup$ @AlexeyPopkov Correct. That is what you should get. Notice that you don't get the dynamic colour swatch with all the editing bits which is what he has asked to turn off. $\endgroup$
    – Edmund
    Dec 19, 2015 at 15:51
  • $\begingroup$ Thanks, now I see your point. It seems I misunderstood the question: I thought that the OP wants Red to return RGBColor[1, 0, 0] as it was in the previous versions. BTW the editing palette on my system does not work unless I click the Advanced button, seems to be a bug (version 10.3.1). Does it work for you? $\endgroup$ Dec 19, 2015 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.