0
$\begingroup$

When I enter a string that matches part of the name of an application on Mac, the OS X Spotlight search feature will suggest apps for me to launch. This works for every app except Mathematica:

enter image description here

While the string is recognized (presumably from my history) the application is not suggested, and the only way to launch it is directly from the Finder or some other awkward workaround.

Why would — indeed how couldMathematica behave differently in this regard? What can I do to restore this standard piece of functionality?


Note that this problem is unique to Mathematica. For example for JetBrains apps, I get:

enter image description here

Moreover, it extends to the Finder itself. For example if I search there I get

enter image description here

even though Mathematica is clearly there

enter image description here

I can reproduce this (for Mathematica only) by simply updating (download, open the DMG, drag the new version to the Applications folder, replace). This is indeed unique to Mathematica (in my experience). I update at least one app a day in this or similar ways, and none of them vanish as a result from Spotlight; only Mathematica.


UPDATE: An apparent solution to this problem is available here, though the cause remains a mystery.

$\endgroup$

closed as off-topic by shrx, Yves Klett, dr.blochwave, user9660, Reb.Cabin Dec 15 '15 at 13:40

  • The question does not concern the technical computing software Mathematica by Wolfram Research. Please see the help center to find out about the topics that can be asked here.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    $\begingroup$ Mathematica shows in Spotlight on my Mac with Mac OS X 10.11.2 $\endgroup$ – Bob Hanlon Dec 14 '15 at 14:33
  • $\begingroup$ Works here too. Is it possible you just installed or updated the OS and spotlight hasn't had enough time to index the hard drive? $\endgroup$ – bill s Dec 14 '15 at 14:40
  • 1
    $\begingroup$ I used to have the same problem. I deleted the Spotlight cache, which forced it to reindex the system, and that fixed it. You should try bill s's solution, which seems like a more non-violent way of doing the same thing. $\endgroup$ – Rahul Dec 14 '15 at 16:19
  • 4
    $\begingroup$ I'm voting to close this question as off-topic because this question is unrelated to Mathematica and probably belongs to apple.stackexchange.com $\endgroup$ – shrx Dec 15 '15 at 10:26
  • 1
    $\begingroup$ I am having the same problem. I think this should be reopened, since the issue occurs only with Mathematica, not other software. $\endgroup$ – becko Jul 7 '17 at 10:26
2
$\begingroup$

Apparently, sometimes spotlight fails to index things properly. You can force spotlight to re-index by following the steps here. You can re-index either the whole hard drive or just the desired folder (in this case, the Applications folder).

$\endgroup$
  • $\begingroup$ Note that now that this bug has reappeared (see edit to OP), this solution has stopped working. $\endgroup$ – orome Dec 18 '15 at 18:56
  • $\begingroup$ Any idea why this (a) never happens with any other application and (b) is reproducible for Mathematica (a simple update will reproduce)? $\endgroup$ – orome Dec 24 '15 at 14:57
  • 2
    $\begingroup$ The bug reappeared (again, uniquely to Mathematica) with the "upgrade" to version 11, and this fixed it again (for now). $\endgroup$ – orome Aug 16 '16 at 19:43
  • $\begingroup$ Make sure you add/remove the Applications folder under Macintosh HD, not the Applications folder in your home folder. I did that and was confused for a minute before I realised my mistake. Anyway, probably better to just reindex Macintosh HD. $\endgroup$ – lukejanicke Jan 20 '17 at 4:23
  • $\begingroup$ This is not working. $\endgroup$ – becko Jul 7 '17 at 10:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.