4
$\begingroup$

I am new to Mathematica. Currently I am using Mathematica 10 on Mac Yosemite.

I have tried:

  • Edit the default.nb and core.nb stylesheet. I change the font-size to 18px, and I can see it takes effect on my currently opened notebook, or any new notebooks under current Mathematica session. However, if I quit the Mathematica application (CMD + Q) and reopen Mathematica, the font-size setting of both default.nb and core.nb is reset to 13px.

  • I open the Option Inspector. I can search in the dialog font and then modify the FontSize. But nothing happens, and the Apply button is grey.

  • Changing font-family in both Option Inspector and stylesheet has no effect, the current/future notebooks all display using Courier.

I wonder what I should do to change the default font-size and font-family for all currently opened and future notebooks?

$\endgroup$
5
  • 2
    $\begingroup$ In my experience, it is not recommended that you change the original default.nb notebook. Make a copy of that - say default1.nb - and save it. Whenever you open a new notebook change the stylesheet. Format > Stylesheet > Other and choose default1. It is not a good idea to make every notebook take your stylesheet by default automatically because it would (adversely) affect documentation formatting etc.. $\endgroup$
    – Lotus
    Commented Nov 23, 2015 at 11:33
  • $\begingroup$ @Kuba: Honestly I don't know how to save it. I definitely tried CMD+s. And if I set a different font-family (e.g. Source Code Pro, although the notebook still displays using Courier), the new font-family remains after the reopening, but the font-size is reset to 13px; therefore in some sense, I did saved the default.nb $\endgroup$
    – Lelouch
    Commented Nov 23, 2015 at 11:38
  • $\begingroup$ @Lotus: Thanks. I can save default1.nb and then apply it successfully, without the resetting-of-font-size problem. Although change in font-family never have any effect still. $\endgroup$
    – Lelouch
    Commented Nov 23, 2015 at 11:46
  • $\begingroup$ From what I can recall with my earlier dealings with such issues, these settings that you made are getting over-written by other settings. What you see on your notebook is decided by several levels of settings. $\endgroup$
    – Lotus
    Commented Nov 23, 2015 at 14:28
  • $\begingroup$ @Lotus: yes I make the same guess, but have no idea what is overwriting things. I also changed the core.nb, but it didn't help. Now I am using default1.nb, and load it every time. $\endgroup$
    – Lelouch
    Commented Nov 23, 2015 at 14:31

1 Answer 1

6
$\begingroup$

Never edit the core and default stylesheets. Go to Menu > Edit Stylesheet... and make whatever modifications you desire. If you are unsure then there are many posts on here if you search. When you have modified the stylesheets install this new stylesheet.

enter image description here

Edit

this question is a duplicate of

How to modify font for all text fields?

How do I set the fonts for Input and Output in my stylesheet?

$\endgroup$
3
  • $\begingroup$ Yes, I did as you described. The font-size is good now, but any change of font-family of input/output cell still has no effect (for chapter cell the changes take effect immediately though). Can the font-family be changed for input and output? $\endgroup$
    – Lelouch
    Commented Nov 24, 2015 at 6:10
  • $\begingroup$ That, as indeed the current question, have been answered before on the site. If you do a search you will find it $\endgroup$ Commented Nov 24, 2015 at 6:21
  • $\begingroup$ how did you make that cool animated gif of the screen interaction? so much more informative than a sequence of screen shots! $\endgroup$
    – Reb.Cabin
    Commented Apr 13, 2016 at 16:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.