10
$\begingroup$

Bug introduced in 10.0.0 and fixed in 10.1


I'm using Mathematica 10.0 on Windows 10. If I take a map of any country (even continent), it automatically adjusts the size of the map.

GeoGraphics[Polygon@EntityClass["Country", "Europe"]]

enter image description here

Except of Russia that reflects the whole map.

GeoGraphics[Polygon@Entity["Country", "Russia"]]

enter image description here

Is it a sort of a bug for Mathematica V 10.0? Can somebody reproduce this behaviour of the Russian map?

$\endgroup$
10
  • $\begingroup$ Can't reproduce your problem. See "answer" below. $\endgroup$
    – m_goldberg
    Nov 22, 2015 at 18:48
  • 1
    $\begingroup$ That seems to narrow it down to Windows or V10.0. That takes me out of the game. I don't have access to such software. $\endgroup$
    – m_goldberg
    Nov 22, 2015 at 19:24
  • 3
    $\begingroup$ @garej Please, do not delete the question. It is relevant for other people with the same version. There is also specific tag bugs for confirmed bugs. $\endgroup$
    – ybeltukov
    Nov 22, 2015 at 19:52
  • 1
    $\begingroup$ @ChipHurst You know, there is no certain edge. It looks like undesired behavior. All other countries looks much better and the answer depends on your origin :) $\endgroup$
    – ybeltukov
    Nov 22, 2015 at 20:25
  • 2
    $\begingroup$ in Soviet Russia, planet adjusts to fit country. $\endgroup$ Nov 23, 2015 at 6:03

3 Answers 3

14
$\begingroup$

It is version 10.0 specific bug. Please upgrade to a more recent version

Version 10.0.0:

enter image description here

Version 10.1 and above:

enter image description here

Tested on Linux. It seems that other OS have the same behavior.


One can extract proper options from recent version and put them to 10.0.0:

GeoGraphics[Polygon@Entity["Country", "Russia"],
 GeoProjection -> {"LambertAzimuthal", 
     "Centering" -> GeoPosition[{59.4954, 105.06}]}, GeoRange -> All, 
 GeoZoomLevel -> 3, PlotRange -> {{-0.884836, 0.884836}, {-0.349549, 
       0.531066}}]

enter image description here

$\endgroup$
3
  • $\begingroup$ Mother Russia is still too big :) $\endgroup$
    – eldo
    Nov 22, 2015 at 19:48
  • $\begingroup$ @ybeltukov, may I ask you to check also this GeoListPlot[ Polygon@Entity["AdministrativeDivision", {"Chukotka", "Russia"}], GeoRange -> {{40, 80}, {0, 200}}, GeoProjection -> "Albers"]. I have a part of Chukotka not included. (is it due to GeoProjection?) $\endgroup$
    – garej
    Nov 22, 2015 at 20:40
  • $\begingroup$ @garej I get this in version 10.0.0. I propose to use my last example in the answer. $\endgroup$
    – ybeltukov
    Nov 22, 2015 at 20:45
5
$\begingroup$

I have the same difficulties with 10.0 on Windows. The best I can get to display the complete area of Russia is

GeoGraphics[Polygon @ Entity["Country", "Russia"], 
 GeoProjection -> "Mercator",
 GeoRange -> {{40, 80}, {25, 195}}, 
 ImageSize -> 600]

Update

To also show Kaliningrad in the far west

GeoGraphics[{
  PointSize[0.02],
  Point[GeoPosition[Entity["City", {"Kaliningrad", "Kaliningrad", "Russia"}]]],
  Polygon@Entity["Country", "Russia"]},
 GeoProjection -> "Mercator",
 GeoRange -> {{40, 80}, {18, 195}},
 ImageSize -> 600]

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ add some space to the left, Kaliningrad left outside =)) $\endgroup$
    – garej
    Nov 22, 2015 at 20:04
  • 1
    $\begingroup$ Of course ! See update :) $\endgroup$
    – eldo
    Nov 22, 2015 at 20:34
3
$\begingroup$

This is not an answer; it is a comment that needs to show an image.

I don't get what you show from

GeoGraphics[Polygon @ Entity["Country", "Russia"]]

I get

map

I evaluated your code with V10.3 running on OS X 10.10.2.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.