3 added 44 characters in body
source | link

Option "RepeatedSeparators" -> False solves the problem:

file = "\"5\";\"8\";\"2803\";
\"\";\"6\";\"2793\";";

ImportString[file, "Table", "FieldSeparators" -> ";", "RepeatedSeparators" -> False]
{{5, 8, 2803, ""}, {"", 6, 2793, ""}}

Although I would consider the default behavior as a bug: the element "" (substring "\"\"" of the whole file) shouldn't be interpreted as an absence of a field, it is just an empty string "" which is a perfectly valid field!

Option "RepeatedSeparators" -> False solves the problem:

file = "\"5\";\"8\";\"2803\";
\"\";\"6\";\"2793\";";

ImportString[file, "Table", "FieldSeparators" -> ";", "RepeatedSeparators" -> False]
{{5, 8, 2803, ""}, {"", 6, 2793, ""}}

Although I would consider the default behavior as a bug: the element "" shouldn't be interpreted as an absence of a field, it is just an empty string which is a perfectly valid field!

Option "RepeatedSeparators" -> False solves the problem:

file = "\"5\";\"8\";\"2803\";
\"\";\"6\";\"2793\";";

ImportString[file, "Table", "FieldSeparators" -> ";", "RepeatedSeparators" -> False]
{{5, 8, 2803, ""}, {"", 6, 2793, ""}}

Although I would consider the default behavior as a bug: the element "" (substring "\"\"" of the whole file) shouldn't be interpreted as an absence of a field, it is just an empty string "" which is a perfectly valid field!

2 added 189 characters in body
source | link

Option "RepeatedSeparators" -> False solves the problem:

file = "\"5\";\"8\";\"2803\";
\"\";\"6\";\"2793\";";

ImportString[file, "Table", "FieldSeparators" -> ";", "RepeatedSeparators" -> False]
{{5, 8, 2803, ""}, {"", 6, 2793, ""}}

Although I would consider the default behavior as a bug: the element "" shouldn't be interpreted as an absence of a field, it is just an empty string which is a perfectly valid field!

Option "RepeatedSeparators" -> False solves the problem:

file = "\"5\";\"8\";\"2803\";
\"\";\"6\";\"2793\";";

ImportString[file, "Table", "FieldSeparators" -> ";", "RepeatedSeparators" -> False]
{{5, 8, 2803, ""}, {"", 6, 2793, ""}}

Option "RepeatedSeparators" -> False solves the problem:

file = "\"5\";\"8\";\"2803\";
\"\";\"6\";\"2793\";";

ImportString[file, "Table", "FieldSeparators" -> ";", "RepeatedSeparators" -> False]
{{5, 8, 2803, ""}, {"", 6, 2793, ""}}

Although I would consider the default behavior as a bug: the element "" shouldn't be interpreted as an absence of a field, it is just an empty string which is a perfectly valid field!

1
source | link

Option "RepeatedSeparators" -> False solves the problem:

file = "\"5\";\"8\";\"2803\";
\"\";\"6\";\"2793\";";

ImportString[file, "Table", "FieldSeparators" -> ";", "RepeatedSeparators" -> False]
{{5, 8, 2803, ""}, {"", 6, 2793, ""}}