Tag Info

New answers tagged

0

This did not work for me because I wanted to create a Windows CSV file from a Macintosh. I tried DOSTextFormat->True but it did nothing. I found that you have the most control using the "Table" format because you can set the field and line separators. For CSV windows files: Export[fileToWrite, avgdata, "Table", "FieldSeparators" -> ",", ...


3

This is not a bug. It is a well known limitation when running the kernel on a headless server on Linux. Some operations require the Front End. Importing TeX is such an operation. The Front End requires an X server, regardless of what it's being used for. Simple solution: use Xvfb as the X server. Ref: ...


2

After managing to reproduce the problem (using Mathematica 8.0.0.0) and looking into an strace I come to the following result: After issuing the ToExpression["x=4-2", TeXForm], the kernel start a front end: 15166 execve("[...]/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica", ["[...]/SystemFiles/F"..., "-topDirectory", "/misc/psi/math-8.0", ...


0

Update: Mathematica 10 seems to have resolved this issue, via the "Always Exit after closing last window" option in Preferences->Interface. David, it looks like they actually listened to your suggestion!



Top 50 recent answers are included