Tag Info

New answers tagged

1

Considering work-arounds, Style and Inactivate seem to work well together. Plot[x , {x, 0, 1}, AxesLabel -> {Style["M", Italic], Style[Inactivate[InputForm[E] = M c^2, (Set | Times)], "TraditionalForm"]}] Inactivating Times keeps M c^2 from being rewritten to c^2 M.


5

I'm not sure what's going on with HoldForm[InputForm[ℰ]], but I think I know what's going on with Plot. It appears at some point ReleaseHold is called because wrapping HoldForm twice fixes your problem. Plot[x^2, {x, -2, 2}, AxesLabel -> {x, HoldForm[HoldForm[InputForm[E = 1]]]}]


6

I can't comment on exactly why HoldForm has changed but I believe your examples fall under the purview of the new Active/Inactive functionality. For example: Clear[x]; Plot[Sin[x], {x, 0, 1}, AxesLabel -> {Inactivate[x = 3], Inactive[Set][InputForm[E], 3]}] x Note, however that Inactivate can't be used with InputForm, since you want InputForm to ...


1

Use value -> label in the list of values: Manipulate[ plot[[n]], {plot, {rawplots -> "foo", weightplots -> "bar", linearizedplots -> "baz"}, PopupMenu} ]


2

Most likely you merely set to some $FrontEnd options unintentionally. If you can figure out what these options are you can reset them by clicking the X next to the field in the Option Inspector: You can also select as text rather than by category to see a list of all the options that have been changed from the default (manually or otherwise).


1

In Linux this still works: and even in the official documentation the shortcuts are still listed under Format Menu. This problem seems to be local to your machine.


5

You need to set CellLabelAutoDelete->False You can do this programmatically: SetOptions[EvaluationNotebook[],CellLabelAutoDelete->False] or set it in your stylesheet.


0

Alexey Popkov was right in his comment, see "How to avoid font substitution with Mathematica fonts?": http://mathematica.stackexchange.com/a/18980/280 Even though in the Mathematica help files you may not find "OperatorSubstitution" anywhere, but if you add BaseStyle -> {PrivateFontOptions -> {"OperatorSubstitution" -> False}} within your code, ...



Top 50 recent answers are included